Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1645 closed enhancement (wontfix)

Unit movement system logic

Reported by: EP Owned by:
Priority: If Time Permits Milestone:
Component: Core engine Keywords:
Cc: vacancy@… Patch:

Description

The movements of units will be more logical if they will choose the shortest path from one point to another on explored part/parts of a map if such path exists.

If there is no such existing path units will choose standart movement logic and go through unknown territory.

Change History (4)

comment:1 Changed 7 years ago by Erik Johansson

Resolution: wontfix
Status: newclosed

How is that logical? You have to remember that this is a game, and then it's most logical for units to take the shortest path to the goal, not to go through "known" territory which might be more logical in reality. In the game the units should think for themselves in this kind of way, at least not in the kind of game that 0 A.D. is, if you as a player want the units to take a certain route to a goal, *you* make them take that route ;)

Version 0, edited 7 years ago by Erik Johansson (next)

comment:2 Changed 7 years ago by zoot

I guess the problem is that sometimes the pathfinder will send e.g. your female citizens into enemy territory / grave danger, even when a safe path is known.

comment:3 Changed 7 years ago by Erik Johansson

Hmm, that's another thing. And I'm not 100% sure the game should take care of that for you either, at least not the pathfinder. It might however make sense to implement a function for e.g. the stances where the more avoidance related stances (which probably should be the only stance for female citizens) stay out of enemy territory or something. Grave danger sounds like a difficult thing for the game to gauge. Either way, that (and to a great degree the topic of the ticket as well) is not so much a bug as a suggestion for how to do things, and those are best discussed in the forums.

comment:4 Changed 7 years ago by historic_bruno

Milestone: Backlog
Note: See TracTickets for help on using tickets.