Opened 7 years ago

Closed 14 months ago

Last modified 14 months ago

#2679 closed defect (fixed)

Visible Garrisoning in animated gate bug

Reported by: stanislas69 Owned by: wraitii
Priority: Nice to Have Milestone: Alpha 24
Component: Simulation Keywords:
Cc: Patch: Phab:D2775

Description (last modified by stanislas69)

It would be nice to to have animated meshes like boats with units on them, without losing the animation.

This currently works with siege towers however it doesn't work well with things like gates.

To reproduce this download the terra magna mod and play around garrisoning the Chinese gate. If it's not locked and you garrison units inside it the gate will stay open. If it's locked, it'll stay closed, and correctly switch to the right anim when opening then it won't close anymore.

Another story happens with garrison flags. If the gate is garrisoned the flags will appear. They'll have their Idle animation set. What will happen is if you try to move units near the gate the same bugs as before will occur and also the flags will freeze as they will be set to an anim they do not have, such as gate_opening, gate_closing, gate_closed, gate_opened. They ought to play Idle in this case.

Change History (12)

comment:1 by sanderd17, 5 years ago

In 18266:

Allow simulation to set the actor variant selection, and use it for the garrison flag. Fixes #3952 Refs #2679, #3983

comment:2 by stanislas69, 4 years ago

Description: modified (diff)
Summary: Garisonnable Units in Animated meshesVisible Garrisoning in animated gate bug

comment:3 by temple, 3 years ago

Phab:D1418 for correct opening and closing of garrisoned gates.

comment:4 by stanislas69, 3 years ago

Milestone: BacklogWork In Progress

comment:5 by Imarok, 2 years ago

Component: UI & SimulationSimulation

Move tickets to Simulation as UI & Simulation got some sub components.

comment:6 by wraitii, 2 years ago

I think this also has a visual component: if gates receive contradictory orders on the same turn (ie. they start closed, then open, then close again on the same turn) they'll 'reset' their animation.

I don't really see a very good fix for that except if only actually open/close in "Update-End" to sorta make sure that all messages have gone through.

comment:7 by wraitii, 14 months ago

Owner: set to wraitii
Resolution: fixed
Status: newclosed

In 23710:

Enable garrisoning on gates / fix movement of units with visible garrison points

This addresses two related issues:

  • Units visibly garrisoned on gates keep the gate open.
  • Units visibly garrisoned on entities keep their pathfinding blocker flags.

Remove the block-movement flag from visibly garrisoned entities.
Keep a list of entities that cannot move and thus should not count towards gate-opening logic.

Packing logic is kept separate: it is more related to entities having 'alternate forms' with different capabilities than being currently incapable of moving.

Based on work by temple

Comments by: Freagarach

Tested by: Nescio

Fixes #2679
Fixes #5151

Differential Revision: https://code.wildfiregames.com/D1418

comment:8 by wraitii, 14 months ago

Patch: Phab: D2775
Resolution: fixed
Status: closedreopened

Changes reverted, reopened at D2775

comment:9 by wraitii, 14 months ago

Patch: Phab: D2775Phab:D2775

comment:10 by wraitii, 14 months ago

Resolution: fixed
Status: reopenedclosed

In 23731:

Enable garrisoning on gates / fix movement of units with visible garrison points (2nd commit)

This is the same commit as rP23710 / D1418, fixing noted issues.

This addresses two related issues:

  • Units visibly garrisoned on gates keep the gate open.
  • Units visibly garrisoned on entities keep their pathfinding blocker flags.

De-activate the obstruction of visibly-garrisoned entities, fixing the 2nd issue.
Keep a list of entities that cannot move and thus should not count towards gate-opening logic.

Packing logic is kept separate: it is more related to entities having 'alternate forms' with different capabilities than being currently incapable of moving.

Based on work by temple

Fixes #2679.
Fixes #5151.

Differential Revision: https://code.wildfiregames.com/D2775

comment:11 by stanislas69, 14 months ago

Milestone: Work In ProgressAlpha 24

Should we open another ticket for gates resetting each time you have a new unit in them?

comment:12 by wraitii, 14 months ago

I think so, it's rather unrelated. It happens because the garrisonHolder sets the garrisoned flag, which sets the animation, which then reruns from scratch.

Note: See TracTickets for help on using tickets.