Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2689 closed defect (fixed)

Not able to get run 0ad from another account (0ad-0.0.16-alpha-osx64.dmg)

Reported by: Ludovic Rousseau Owned by: ben
Priority: Must Have Milestone: Alpha 18
Component: Build & Packages Keywords:
Cc: Patch:

Description

The Mac OS X package for version alpha-16 has a problem.

How to reproduce:

  1. install the game as user1
  2. switch to user2
  3. run the 0ad application

You will get an error that localization can't be used and the game exits.

This is because the directory Contents/Resources/data/l10n not created with the correct file access rights. The directory can't be used by the group or other.

./Contents/Resources/data:
total 0
drwxr-xr-x@ 5 rousseau  admin  170 23 jui 14:26 config
drwx------@ 2 rousseau  admin   68 23 jui 14:47 l10n
drwxr-xr-x@ 3 rousseau  admin  102 23 jui 13:54 mods
drwxr-xr-x@ 4 rousseau  admin  136 23 jui 14:26 tools

The fix is simple.

$ chmod go+rx [...]/0ad.app/Contents/Resources/data/l10n

The .dmg should be regenerated.

Thanks for this great game!

Change History (10)

comment:1 by Stan‘, 8 years ago

Component: Build & PackagesCore engine
Milestone: Alpha 17

This had no milestone, don't know if it was intended just in case move it back to A17

comment:2 by historic_bruno, 8 years ago

Cc: wraitii added
Component: Core engineBuild & Packages

comment:3 by Itms, 8 years ago

Milestone: Alpha 17Backlog

comment:4 by Stan‘, 8 years ago

Keywords: unanswered added

comment:5 by Ludovic Rousseau, 8 years ago

The bug is still present in Alpha 17

comment:6 by historic_bruno, 8 years ago

Looking at build-osx-bundle.sh, it never even copies the l10n directory, so I'm extremely confused as to how it ended up in the bundle with incorrect permissions. Maybe it's created by the game somehow? It seems the real problem is in the bundle build script, I will fix that and rebuild.

comment:7 by historic_bruno, 8 years ago

Cc: wraitii removed
Keywords: unanswered removed
Milestone: BacklogAlpha 18
Priority: Should HaveMust Have

comment:8 by ben, 8 years ago

Owner: set to ben
Resolution: fixed
Status: newclosed

In 15878:

Adds missing l10n folder to OS X bundle build script, fixes #2689

comment:9 by historic_bruno, 8 years ago

Indeed the problem was the l10n folder not being copied to the bundle, though the game creates an empty one with default permissions when run the first time (standard VFS behavior, not desirable in this case). For most users, this caused no visible problem, as only a handful of engine strings are being translated (notably, the screenshot and saved game messages) that are easy to miss and the permissions would be ok since they are the owner. I guess there aren't many people playing the game with multiple user accounts and internationalization on OS X, either that or they didn't bother to report the crash :P

comment:10 by historic_bruno, 8 years ago

New A17 bundle is uploaded.

Note: See TracTickets for help on using tickets.