Opened 6 years ago

Last modified 15 months ago

#2988 assigned enhancement

[PATCH] Improve performance Object List Filter Atlas

Reported by: trompetin17 Owned by: trompetin17
Priority: Should Have Milestone: Backlog
Component: Atlas editor Keywords: patch
Cc: Patch: Phab:D2040

Description

this patch change wxListbox for wxListView, and change hardcode loop(vector iterator) for std::for_each

Attachments (1)

2988.diff (5.6 KB ) - added by trompetin17 6 years ago.

Download all attachments as: .zip

Change History (9)

by trompetin17, 6 years ago

Attachment: 2988.diff added

comment:1 by trompetin17, 6 years ago

Owner: set to trompetin17
Status: newassigned
Summary: Improve performance Object List Filter Atlas[PATCH] Improve performance Object List Filter Atlas

comment:2 by historic_bruno, 6 years ago

Replacing wxListbox with wxListView seems like it might be a good idea. I'm not sure about the filter function redesign though, is that really more efficient? It looks much less readable to me and the g_itemIdListView global variable is yucky.

comment:3 by historic_bruno, 6 years ago

Keywords: Atlas review removed

comment:4 by Itms, 6 years ago

Milestone: Alpha 18Alpha 19

Pushing after IRC discussion.

comment:5 by Itms, 5 years ago

Milestone: Alpha 19Alpha 20

comment:6 by elexis, 5 years ago

Milestone: Alpha 20Backlog

comment:7 by trompetin17, 15 months ago

Patch: Phab:D2040

comment:8 by trompetin17, 15 months ago

Change the way I filtered the list

Note: See TracTickets for help on using tickets.