Opened 5 years ago

Closed 5 years ago

#3141 closed defect (duplicate)

Error: Failed to load entity template 'structures/celt_sb1'

Reported by: elpato Owned by:
Priority: Should Have Milestone:
Component: UI & Simulation Keywords:
Cc: Patch:

Description

Hey,

I have found a bug that is quite annoying, as the same error message keeps popping up every few ms on screen, and in the console. Not sure if/how it affects the gameplay itself in its case, as it feels unplayable with all the errors printed on the screen (I mean for one particular scenario; overall, I really like the game and haven't found any other bugs so far).

It does it without fail if I do the following steps:

  • Select Single-Player, Matches
  • Change Map Type to Scenario
  • Select Map: Azure Coast 3
  • Assign your player to one of the Celt civilizations (North or South)
  • Leave the rest as Petra bot
  • Start game

Playing as Hellenic works fine, so I guess it's just missing some kind of script for the gauls.The exact error is:

ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/structures/celt_sb1.xml" Error: Failed to load entity template 'structures/celt_sb1'

Using the latest Alpha from the Arch repos.

$ pacman -Qs 0ad
local/0ad a18-1
    Cross-platform, 3D and historically-based real-time strategy game
local/0ad-data a18-1
    Cross-platform, 3D and historically-based real-time strategy game (data files)

The messages disappear if I quit the game, so I can play if I change the settings, so it's not a huge deal, but it would be nice to have the option to play as the Gauls.

Aside from that, thanks for the superb game!

Change History (3)

comment:1 Changed 5 years ago by trompetin17

are you using svn version or 0A18 version?

comment:2 Changed 5 years ago by elpato

Alpha 18, from the repos. Not the SVN version.

Build: March 14th, 16411P-release.

comment:3 Changed 5 years ago by leper

Component: Core engineUI & Simulation
Milestone: Backlog
Resolution: duplicate
Status: newclosed

Fixed in r16416, so this is a duplicate of #2619.

Note: See TracTickets for help on using tickets.