Opened 4 years ago

Closed 4 years ago

#3547 closed defect (duplicate)

Open developers overlay in rated games by rejoining via IP

Reported by: elexis Owned by:
Priority: Must Have Milestone:
Component: UI & Simulation Keywords:
Cc: Patch:

Description (last modified by elexis)

Rated games should not allow the developers overlay. For example you can change the perspective to your enemy and delete all units or click on control-all-units and do the same.

Reproduce:

  1. Alice starts a rated game in the lobby
  2. Bob joins the game
  3. The game starts
  4. Bob disconnects
  5. Bob leaves the lobby
  6. Bob clicks on multiplayer -> Join -> Connect

Bob has rejoined the game, can now open the developers overlay and loot the rating.

Refs #3155 #3537 #3546

Change History (2)

comment:1 Changed 4 years ago by elexis

Description: modified (diff)

Reportedly there is also a similar persist-match-settings bug:

1. Alice hosts a rated game in the lobby 2. Bob joins that game from the lobby 3. The game starts 4. Bob leaves the game 5. Bob starts a non-lobbied game with ratings disabled and ends it 6. Bob returns to the lobby, rejoins the rated game and can now open the developers overlay. (could not reproduce this alleged bug)

Last edited 4 years ago by elexis (previous) (diff)

comment:2 Changed 4 years ago by elexis

Keywords: simple removed
Milestone: Backlog
Resolution: duplicate
Status: newclosed

Closing as duplicate of #2676 and #3551 as it's the same discussion.

Note: See TracTickets for help on using tickets.