Opened 5 years ago

Closed 3 years ago

#3678 closed defect (wontfix)

Introductory tutorial: 1 warning and 2 minor glitches

Reported by: fabio Owned by:
Priority: Should Have Milestone:
Component: Core engine Keywords:
Cc: leper Patch:

Description (last modified by mimo)

As soon as starting it this message appear:

WARNING: JavaScript warning: simulation/ai/tutorial-ai/config.js line 57
mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create

The message:

Now that you are in City Phase, build a fortress...

happens before being in City Phase.

The message:

The enemy base has been spotted...

happens before discovering it.

Change History (2)

comment:1 by fcxSanya, 5 years ago

I think we can close this ticket as a duplicate of #2303 and add all the issues into a checklist (to test after rewriting via triggers) there.

comment:2 by mimo, 3 years ago

Description: modified (diff)
Milestone: Backlog
Resolution: wontfix
Status: newclosed

the tutorial was rewritten using triggers, and tutorial-ai has been removed.

Note: See TracTickets for help on using tickets.