Opened 19 months ago

Closed 18 months ago

Last modified 18 months ago

#3983 closed enhancement (fixed)

[PATCH] Different variants for different health levels

Reported by: sanderd17 Owned by: sanderd17
Priority: Should Have Milestone: Alpha 21
Component: UI & Simulation Keywords: patch
Cc: Patch:

Description

The patch below implements variant selection based on health level.

Artists can choose how many different health levels they want, or when to switch to a different variant. Via inheritance, there can be a standard for the number of levels based on the entity type (important entities can have a finer granulation), so specific templates don't need a lot of updates (though actors will need updates).

It implements the change for the Iberian fire ship; adding more fire and smoke when it's decaying.

The patch depends on #3952.

Attachments (4)

damageVariants.diff (7.1 KB) - added by sanderd17 19 months ago.
damageAndSeasonVariants.diff (12.1 KB) - added by sanderd17 18 months ago.
damageVariants.2.diff (8.8 KB) - added by sanderd17 18 months ago.
damageVariants.3.diff (8.7 KB) - added by sanderd17 18 months ago.
Fix issue with message format

Download all attachments as: .zip

Change History (11)

Changed 19 months ago by sanderd17

Attachment: damageVariants.diff added

comment:1 Changed 19 months ago by stanislas69

I think that's a dupe of #131

Changed 18 months ago by sanderd17

comment:2 Changed 18 months ago by sanderd17

New patch refactors some code, and now also allows actors to have differences based on season (defined in the map data).

It's implemented for the Gaul CC (as celts have a snow texture, though the snow texture isn't compatible with newer celtic buildings)

This should really be a follow up ticket, but this sort of incremental patches with new files are hard to maintain, so I just put it here.

comment:3 Changed 18 months ago by sanderd17

In 18266:

Allow simulation to set the actor variant selection, and use it for the garrison flag. Fixes #3952 Refs #2679, #3983

Changed 18 months ago by sanderd17

Attachment: damageVariants.2.diff added

comment:4 Changed 18 months ago by sanderd17

New proposal, it's now part of the Health component, which is a bit cleaner IMO, and it should also have less performance issues than the previous one (doesn't add unneeded message listeners).

Changed 18 months ago by sanderd17

Attachment: damageVariants.3.diff added

Fix issue with message format

comment:5 Changed 18 months ago by sanderd17

Owner: set to sanderd17
Resolution: fixed
Status: newclosed

In 18340:

Implement damage variants with an example for the Iberian fire ship. Fixes #3983

comment:6 Changed 18 months ago by sanderd17

Keywords: review removed

comment:7 Changed 18 months ago by stanislas69

refs #131

Note: See TracTickets for help on using tickets.