Opened 7 years ago

Closed 5 years ago

#3998 closed defect (duplicate)

GameAttributes PlayerData should contain gaia

Reported by: elexis Owned by:
Priority: Should Have Milestone:
Component: UI & Simulation Keywords:
Cc: Patch:

Description (last modified by elexis)

Some maps (f.e. Northern Island) add a null item to the playerData array of the gamesettings representing gaia while most other maps don't.

Similarly many places in the code have arrays with gaia in it, while other places don't, resulting array indices to be off by one often, f.e. in source:ps/trunk/binaries/data/mods/public/maps/random/rmgen/library.js

Instead every map should have a gaia item, which should not only remove the +1 / -1 index operations but also could allow mapmakers to add configuration for gaia (f.e. an AI).

Change History (1)

comment:1 by elexis, 5 years ago

Description: modified (diff)
Milestone: Backlog
Resolution: duplicate
Status: newclosed

Duplicate of #3886

Note: See TracTickets for help on using tickets.