#4065 closed enhancement (fixed)

[PATCH] Make quinqueremes/heavy warships useful for siege

Reported by: causative Owned by: elexis
Priority: Should Have Milestone: Alpha 21
Component: UI & Simulation Keywords: patch
Cc: Patch:

Description (last modified by causative)

Heavy warships with 5-10 catapults garrisoned are extremely expensive, so they ought to be worth it. Heavy warships deal 30 crush and 30 hack damage per catapult garrisoned. This isn't enough damage to use them to attack fortified positions on the shore. With five catapults garrisoned, it would take at least 2 minutes to destroy a fortress, and a heavy warship can't stand up to a garrisoned fortress for that long. It also isn't even enough damage to compete with garrisoned medium warships in ship-to-ship combat. For more details on the balance, see the first post of this thread: https://wildfiregames.com/forum/index.php?/topic/20835-balance-heavy-warships-too-weak/ (note that the thread digresses into a question of historical accuracy. Just the first post makes the case for game balance.)

My proposed solution in that thread is to increase the damage per shot of the heavy warship to 100 crush 10 pierce per shot, the same as the catapults they are carrying. elexis endorsed this plan and suggested I submit this patch.

There is an additional balance consideration, which is that although garrisoning a heavy warship with catapults is extremely expensive, an ungarrisoned heavy warship is cheap (200 wood 200 metal) compared to the cost of a catapult (350 wood 350 stone). Therefore, in this patch I increase the cost of heavy warships to 350 wood 200 metal 350 stone, to encourage players to garrison catapults instead of just making more warships. This change might not be necessary, since my testing indicates that ungarrisoned heavy warships can't break shore defenses well even if you have a bunch of them, because you can't pack them together tightly enough to concentrate fire.

Additional minor changes in this patch: I changed the splash damage to be the same as a catapult, just for consistency, not for any balance reason. (That's actually a slight nerf to damage). I increased the MaxArrowCount? from 10 to 11 to be consistent with the tooltip which says you can increase the arrow count by garrisoning up to 10 catapults (with MaxArrowCount? = 10, you could only increase the count by garrisoning up to 9 catapults).

The Ptolemy Juggernaut depends on the Quinquereme template, so I also increased the cost of a Juggernaut, to 400 wood 300 metal 350 stone. This is just so that it still costs more than a normal heavy warship.

I have tested this change for balance. Here are my findings. First, ship-to-ship combat:

  1. An empty heavy warship is now approximately equal to an empty Briton medium warship. It depends on the range - heavy warships are better at close range because their shots have a higher spread and therefore often miss at larger ranges. In one test, the heavy warship won with 281/2000 HP remaining.
  2. A heavy warship with 5 catapults garrisoned is somewhat better than a Briton medium warship with 10 garrison. In one test, the heavy warship won with 573/2000 HP remaining. Note that the heavy warship is vastly more expensive: total cost of the medium warship + 10 garrison is 650 wood, 500 food, 150 metal, 13 population, assuming the garrison costs 50 food 50 wood each. Total cost of the heavy warship + 5 garrison is 2100 stone, 2100 wood, 200 metal, 18 population.

So, heavy warships with this change are slightly stronger than medium warships, but far too expensive for ship-to-ship combat. That's OK, I think, if the intended purpose of heavy warships is siege.

Second, testing for siege:

  1. I created some shore defenses with 2 garrisoned defense towers, 1 fully garrisoned fortress, and a few citizen soldier archers and slingers milling around on the shore. One heavy warship with 10 catapults garrisoned and all 3 armor upgrades was unable to destroy these defenses - it had to go back for repairs after killing one tower. It is not possible to focus down the fortress, because the heavy warship randomly targets the towers and the citizen soldiers as well.
  2. Two heavy warships with 5 catapults each and all 3 armor upgrades were able to destroy the shore defense, with one at 75% health IIRC and the other around 50% health. The total cost of these warships and garrison was 4200 stone, 4200 wood, 400 metal, 36 population.

So, heavy warships with this change are able to take out shore defenses, at large expense. It may be advisable to send in some medium warships with them to help tank the damage and kill shore units.

The cost might seem prohibitive. However, it is balanced and useful in certain games. If the game has reached a state where you have way more resources than you need, but the opponent has heavily fortified his shoreline and you aren't making progress, 8800 resources would be a reasonable price to break the stalemate.

Attachments (1)

heavywarship.diff (2.2 KB) - added by causative 17 months ago.

Download all attachments as: .zip

Change History (6)

Changed 17 months ago by causative

Attachment: heavywarship.diff added

comment:1 Changed 17 months ago by causative

Just as a comment, let me propose some balance solutions in addition to or instead of this patch, in case they are still too weak.

  1. Give the heavy warship 80+ range in addition to dealing 100 crush damage per shot. This might just make it too easy to destroy defenses.
  2. Increase the heavy warship's HP, e.g. double it.
  3. Reduce their cost back to 200 metal 200 wood. Testing indicates that empty heavy warships under this patch aren't really that powerful because you have trouble crowding enough of them together to concentrate fire. This is a small balance change really since heavy warships aren't very useful until you garrison them, and then most of the cost is their garrison.
  4. Instead of this patch, change heavy warships so their arrow count increases with garrisoned infantry, not garrisoned catapults. This would solve the ridiculous garrison cost problem and allow heavy warships to be balanced around ship-to-ship combat, while still dealing crush damage for siege.

comment:2 Changed 17 months ago by causative

Description: modified (diff)

comment:3 Changed 17 months ago by elexis

As mentioned by fatherbushido the ponies ascendant mod also has some interesting ship balancing, though it seems the ship is not cost/value efficient enough:

https://github.com/0ADMods/ponies_ascendant/blob/master/simulation/templates/units/uni_ship_siege.xml

comment:4 Changed 17 months ago by elexis

Keywords: review balance removed

Thanks for the patch and the thorough reasoning, I can just agree with.

With your patch, they seem strong enough to me. Better be a bit too conservative with buffing before introducing a too OP unit.

Notice in a game the player should focus on killing weak targets first with medium warships / trireme, so there shouldn't be anymore slingers running around on the shoreline. Secondly if there are too many obstructions, the island must be peeled layer by layer like an onion. I reproduced your 1 fort + 2 tower scenario and I can't complain.

Slightly increased the attack range though as it seemed too short to me to wipe buildings from the shoreline.

Btw someone should finally nerf the ship repair rate.

Last edited 17 months ago by elexis (previous) (diff)

comment:5 Changed 17 months ago by elexis

Owner: set to elexis
Resolution: fixed
Status: newclosed

In 18427:

Buff quinquereme, especially the garrisoning of expensive catapults. Patch by causative, fixes #4065.

Note: See TracTickets for help on using tickets.