Opened 3 years ago

Closed 3 years ago

#4080 closed defect (duplicate)

0 A.D. crashes

Reported by: Moody Owned by:
Priority: Should Have Milestone:
Component: UI & Simulation Keywords: crashdump, crashreport
Cc: Patch:

Description (last modified by Moody)

Dear developers,

0 A.D. crashes after playing for a while, and it seems to happen consistently -- around the 10th minute when battles start to happen. Sometimes after the first battle is won the game crashes other times it crashes during a battle.

Moody

Attachments (2)

crashlog.dmp (65.8 KB) - added by Moody 3 years ago.
crashlog.dmp
crashlog.txt (9.8 KB) - added by Moody 3 years ago.
crashlog.txt

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Moody

Attachment: crashlog.dmp added

crashlog.dmp

Changed 3 years ago by Moody

Attachment: crashlog.txt added

crashlog.txt

comment:1 Changed 3 years ago by Moody

Description: modified (diff)

comment:2 Changed 3 years ago by Moody

Description: modified (diff)

comment:3 Changed 3 years ago by elexis

Usually we get those reports when there are out-of-memory errors, though your logs don't indicate that directly. It can also happen if there is enough memory available but fragmented, so that allocating something fails too.

Which settings do you play with? The AI uses a lot of CPU and memory, the mapsize and population count are also very relevant. In multiplayergames we usually limit the population to 150 and mapsize to "normal".

Can you upload one of the replays where it crashed? (Main menu -> tools -> replays. click on delete to find the filename). Does replaying that crash also consistently?

Does it crash when you don't have any AIs?

comment:4 Changed 3 years ago by elexis

Milestone: Backlog
Resolution: duplicate
Status: newclosed

Tagging as duplicate of #4190 since the described problem was most likely caused by the windows binaries only being able to allocate 2GB of memory. This should be solved with the Alpha 21 release. Please reopen the ticket otherwise.

Note: See TracTickets for help on using tickets.