Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#4190 closed enhancement (fixed)

[PATCH] Make 0 A.D. large address aware on Windows for releases

Reported by: Itms Owned by: Itms
Priority: Release Blocker Milestone: Alpha 21
Component: Build & Packages Keywords: patch
Cc: Yves Patch:

Description

As considered in #1619, using the large address aware flag on Windows could fix some memory issues we have, by enabling the use of 2GB of RAM on every machine.

However, this does not fix the underlying memory issues, and worse, it masks them.

Attached patch, based on patch by echotangoecho, adds a build flag adding support for large addresses. This flag should be enabled for the autobuilder, so that release users and SVN playtesters can play without issues, but it shouldn't be enabled when compiling the game with update-workspaces.bat.

Question: How to do that with Jenkins?

Attachments (1)

0002-Large-address-aware.patch (1.5 KB) - added by Itms 15 months ago.

Download all attachments as: .zip

Change History (9)

Changed 15 months ago by Itms

comment:1 Changed 15 months ago by Itms

Keywords: rfc patch added
Summary: Make 0 A.D. large address aware on Windows for releases[PATCH] Make 0 A.D. large address aware on Windows for releases

comment:2 Changed 15 months ago by gameboy

I tested this patch, I hit the shift+f2 button in the game, screenshots failed.

Please update this patch.

Last edited 15 months ago by Itms (previous) (diff)

comment:3 Changed 15 months ago by Itms

This is the intended behavior, use update-workspaces.sh --large-address-aware to build with the flag.

Also please don't abuse formatting on Trac. This is not a forum topic.

comment:4 Changed 15 months ago by gameboy

This patch can solve large screen sectional graph problem, but still make the game screenshots suspended for several seconds, memory usage increases, please fix these problems.

BTW: OK, I know this is not a forum, but please do not arbitrarily in the forum without my consent to delete my post, thank you!

comment:5 in reply to:  4 Changed 15 months ago by Itms

Replying to gameboy:

This patch can solve large screen sectional graph problem, but still make the game screenshots suspended for several seconds, memory usage increases, please fix these problems.

This is normal for a big screenshot.

BTW: OK, I know this is not a forum, but please do not arbitrarily in the forum without my consent to delete my post, thank you!

Your post was not a bug report, and since it had no apparent purpose I couldn't move it to any other forum. If you want, I can put it back but you will have to modify it.

comment:6 Changed 15 months ago by gameboy

Please restore my post in the forum, I will change it, thank you!

Last edited 15 months ago by Itms (previous) (diff)

comment:7 Changed 15 months ago by Itms

Resolution: fixed
Status: newclosed

In 18711:

Add a linker flag on Windows allowing the game to be large address aware. This allows the game to use more than 2GB of RAM. https://msdn.microsoft.com/en-us/library/wz223b1z.aspx

However, this can mask memory issues, so this flag will not be enabled by default. The autobuilder will use it, so SVN playtesters and release users can benefit from it. Windows users compiling the game themselves will have the 2GB limitation.

Fixes #4190, refs #1619, #4191
Flag tested by Stan

comment:8 Changed 15 months ago by Itms

Keywords: rfc removed
Note: See TracTickets for help on using tickets.