Changes between Version 10 and Version 27 of Ticket #4326


Ignore:
Timestamp:
Nov 30, 2016, 10:27:42 PM (7 years ago)
Author:
bb
Comment:

Replying to mimo:

session.placement.js

I would have used randIntExclusive(0, 65535) instead of randIntInclusive(0, 65534)

but that's just a personnal preference

I did change the number because now we set the maximum directly and maximum + 1, but when its better/cleaner to have this another way, I wouln't mind. (Changed the value in GIT for now to 65535)

chatLaunchAttack: the additionnal condition on proba when HugeAttack was mostly because i was short of idea for a good second sentence, so I reused the ones from normal attacks. It would be better to add another sentence and remove this extra condition on proba. And if you also have nice alternate sentences for all these AI dialogs, feel free to add them to make more diversity.

I think its better to split this of into another patch/ticket (patch is already big enough), that hugeAttack thingy can then be changed aswell. (But fully agree, that it should be done.)

chatAnswerRequestAttack: I'm not a fan of interlinked ternaries which i find difficult to read. I prefer an if+ternary

I like the ternary's better here, since we don't need some variable declaration, maybe with inlined strings it would have been a bit unreadable but since they have moved to the top of the file, I don't see why this is unreadable.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #4326

    • Property Keywords rfc added; review removed
    • Property Milestone Alpha 22Work In Progress
  • Ticket #4326 – Description

    v10 v27  
    77- Occurrences of {{{Math.round(Math.Random())}}} and similar expressions should be nuked into some RandInt() calls.
    88
    9 - Occurrences of randFloat(0, value) should be nuked to randFloat(value) as that returns is the exact same interval and saves some performance.
    10 
    119The attached patch is a rebase from #3102 and this ticket is necessary for the final implementation of that ticket.