Opened 4 years ago

Closed 9 months ago

#4332 closed defect (fixed)

Reselect building after promotion tech

Reported by: elexis Owned by:
Priority: Should Have Milestone: Alpha 24
Component: UI – In-game Keywords:
Cc: Patch:

Description (last modified by elexis)

Reproduce:

  1. Start a game with the macedonian civ
  2. Build a fortress
  3. Use the "gift from the gods" cheat
  4. Start the macedonian champion tech research
  5. Once the update runs out, the selection panel still shows the old buttons with the template which can't be trained anymore.
  6. Selecting the fortress again fixes that.

Reported by Prodigalson.

Change History (6)

comment:1 by wraitii, 4 years ago

Would be fixed by D270, the problem is that we cache some things on the Gui side and it doesn't get refreshed.

comment:2 by wraitii, 4 years ago

Milestone: BacklogAlpha 22

comment:3 by elexis, 4 years ago

Milestone: Alpha 22Backlog

Backlogging due to lack of progress

comment:4 by elexis, 4 years ago

Description: modified (diff)

As reported by borg- today in irc, see Phab:D734, the mercenary technology introduced in Phab:D407 is equally affected.

comment:5 by Imarok, 2 years ago

Component: UI & SimulationIn-game UI

Move tickets to In-game UI as UI & Simulation got some sub components.

comment:6 by wraitii, 9 months ago

Milestone: BacklogAlpha 24
Resolution: fixed
Status: newclosed

Fixed by rP23843 / D270

Note: See TracTickets for help on using tickets.