Opened 3 years ago

Last modified 2 years ago

#4361 reopened defect

Crash switching windows with Alt+Tab with dual monitor

Reported by: frapstar Owned by:
Priority: Must Have Milestone: Backlog
Component: Core engine Keywords:
Cc: Patch:

Description

Hi my game crash and i get an error. Please see the log file for more Details.

Attachments (5)

crashlog.dmp (121.7 KB) - added by frapstar 3 years ago.
crashlog.dmp
crashlog.txt (17.5 KB) - added by frapstar 3 years ago.
crashlog.txt
interestinglog.html (3.8 KB) - added by frapstar 3 years ago.
interestinglog.html
mainlog.html (23.4 KB) - added by frapstar 3 years ago.
mainlog.html
system_info.txt (16.2 KB) - added by frapstar 3 years ago.
system_info.txt

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by frapstar

Attachment: crashlog.dmp added

crashlog.dmp

Changed 3 years ago by frapstar

Attachment: crashlog.txt added

crashlog.txt

Changed 3 years ago by frapstar

Attachment: interestinglog.html added

interestinglog.html

Changed 3 years ago by frapstar

Attachment: mainlog.html added

mainlog.html

Changed 3 years ago by frapstar

Attachment: system_info.txt added

system_info.txt

comment:1 Changed 3 years ago by elexis

Component: Non-game systemsCore engine
Milestone: Alpha 22
Resolution: needsinfo
Status: newclosed

The logs say that you tried to load a savegame that didn't have metadata. Could it be that you updated to alpha 21 and tried to load a savegame from alpha 20?

comment:2 Changed 3 years ago by frapstar

No. I install the Game 30 minutes before. A clean install of Alpha 21 Ulysses, no update. And i start a new Game, because there were no savegame, because i install it new on the Computer. The PC has 2 Monitors and the crash was when i switch (alt + tab) to the desktop. when i want to switch back into the game, there was this error.

comment:3 Changed 3 years ago by elexis

Milestone: Backlog
Priority: Should HaveMust Have
Resolution: needsinfo
Status: closedreopened
Summary: Error - crashlogCrash switching windows with Alt+Tab with dual monitor

Well in that case I reopen it. Perhaps the issue is reproducible when switching with alt+tab on dual monitors on other machines as well. Wouldn't be surprised if dual monitor support has some bug, perhaps windowed mode is more stable.

The savegame error still seems unrelated - sounds like a missing check for players without savegames.

comment:4 Changed 3 years ago by frapstar

I try in windows mode = Same error. It crash when i switch do desktop and back in the game. So yes the error is reproducible. I dont have this error at my other pc with only one monitor.

comment:5 Changed 3 years ago by stanislas69

Alt tab has always been buggy on windows.

comment:6 Changed 3 years ago by elexis

In 18997:

Save and load dialog bugfix. Reported by frapstar, refs #4361.

Change a wrong check in the save and load screen that didn't handle the "No saved games found" case.

comment:7 Changed 3 years ago by elexis

Refs #4181

comment:8 Changed 2 years ago by stanislas69

I had a look today and here is the stack trace Maybe that can help someone to debug it.

>	pyrogenesis.exe!PerformErrorReaction(ErrorReactionInternal er, unsigned int flags, volatile int * suppress) Line 426	C++
 	pyrogenesis.exe!debug_DisplayError(const wchar_t * description, unsigned int flags, void * context, const wchar_t * lastFuncToSkip, const wchar_t * pathname, int line, const char * func, volatile int * suppress) Line 483	C++
 	pyrogenesis.exe!wseh_ExceptionFilter(_EXCEPTION_POINTERS * ep) Line 289	C++
 	pyrogenesis.exe!CallStartupWithinTryBlock() Line 365	C++
 	[External Code]	
 	[Frames below may be incorrect and/or missing, no symbols loaded for msvcr120.dll]	
 	pyrogenesis.exe!CRenderer::RenderSubmissions(const CBoundingBoxAligned & waterScissor) Line 1572	C++
 	pyrogenesis.exe!CRenderer::RenderScene(Scene & scene) Line 1875	C++
 	pyrogenesis.exe!CGameView::Render() Line 489	C++
 	pyrogenesis.exe!Render() Line 232	C++
 	pyrogenesis.exe!Frame() Line 358	C++

Note: See TracTickets for help on using tickets.