Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#4632 closed defect (fixed)

Healer range visualization forget tech modifications after loading a game

Reported by: fatherbushido Owned by: elexis
Priority: Must Have Milestone: Alpha 22
Component: UI & Simulation Keywords:
Cc: Patch: Phab:D698

Description

Plan to reproduce in game:

  • select an healer (and notice its range visualization circle)
  • search a range heal tech in temple (and notice the circle is bigger)
  • save the game
  • load the game
  • select that healer, it will have original circle (despite its range is actually modified). Newly create healer will have the modified one.

Attachments (1)

4632_healvis.diff (596 bytes) - added by Sandarac 3 years ago.
Maybe not the best fix, I didn't look into it in depth.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by fatherbushido

Bug confirmed by elexis.

Refs r19519, r19679, r19708

Changed 3 years ago by Sandarac

Attachment: 4632_healvis.diff added

Maybe not the best fix, I didn't look into it in depth.

comment:2 Changed 3 years ago by Sandarac

Milestone: BacklogWork In Progress
Patch: Phab:D698

comment:3 Changed 3 years ago by elexis

Owner: set to elexis
Resolution: fixed
Status: newclosed

In 19861:

Rebuild heal range visualization after deserialization.
Since the RangeVisualization? component is deserialized before the TechnologyManager?, upgraded healers had shown a wrong range.

Differential Revision: https://code.wildfiregames.com/D698
Fixes #4632
Refs D432
Patch By: Sandarac

comment:4 Changed 3 years ago by elexis

Milestone: Work In ProgressAlpha 22

(Good to not have players bug us with reports in the upcoming release)

comment:5 Changed 2 years ago by elexis

In 20963:

Fix range overlay color after deserialization following rP20622 / D555, refs #3915.

Since the component initialization order is the alphabetic filename order and
since the RangeOverlayRenderer? < Player < Selectable, the new file in that commit introduced the issue.
Similar to rP19861, refs #4632.

UpdateColor? function taken from temple's D754

Note: See TracTickets for help on using tickets.