Opened 2 years ago

Closed 2 years ago

#4639 closed defect (fixed)

OSX compilation failure due to outdated zlib

Reported by: elexis Owned by: elexis
Priority: Release Blocker Milestone: Alpha 22
Component: Build & Packages Keywords:
Cc: Patch: Phab:D644

Description

As reported by nigel87, when trying to compile the game from source on OSX, we get the following error:

-e Building zlib...
tar: Unrecognized archive format
tar: Error exit delayed from previous errors.

This seems to be caused by that zlib version simply not being hosted anymore:

This URL returns 404: http://zlib.net/zlib-1.2.8.tar.gz whereas this URL is the only URL that serves correctly on that hostname I could find quickly: http://zlib.net/zlib-1.2.11.tar.gz

As of June 15th 2017, that's the most recent version (released January 15, 2017).

Change History (3)

comment:1 Changed 2 years ago by elexis

Patch: Phab:D644

comment:2 Changed 2 years ago by fabio

#4362 is related, maybe he should test the full update.

comment:3 Changed 2 years ago by elexis

Owner: set to elexis
Resolution: fixed
Status: newclosed

In 19825:

Update OSX zlib version to the most recent and now only one hosted.

Fixes #4639
Refs #4362
Differential Revision: https://code.wildfiregames.com/D644
Tested By: Tobbi

Note: See TracTickets for help on using tickets.