Opened 23 months ago

Closed 3 months ago

#4926 closed defect (worksforme)

AuraManager should distinguish Auras by Aura name, not by Aura effects

Reported by: elexis Owned by:
Priority: Should Have Milestone:
Component: Simulation Keywords:
Cc: Patch:

Description

Reproduce:

  1. Copy the female_inspiration aura
  2. Increase the range in the copy
  3. Give both auras to the template_unit_support_female_citizen.xml
  4. Start a game
  5. Notice at most one of the two auras is applied (Gather rates tooltip)
  6. Stop the game
  7. Increase the multiply values of the copy
  8. Start a game
  9. Notice now both of the auras are applied

Change History (4)

comment:1 Changed 23 months ago by gameboy

Can you release a patch to solve this problem?

comment:2 Changed 9 months ago by Imarok

Component: UI & SimulationSimulation

Move tickets to Simulation as UI & Simulation got some sub components.

comment:3 in reply to:  1 Changed 3 months ago by fatherbushido

Replying to gameboy:

Can you release a patch to solve this problem?

The report was probably wrong, it was just a rounding issue. The ticket is even more probably obsolete since r22767.

comment:4 Changed 3 months ago by elexis

Milestone: Backlog
Resolution: worksforme
Status: newclosed

Not impossible that it was a tooltip rounding issue (toFixed(1)). I've removed the rounding in the GUI, repeated the steps described with current svn, and that seems to work.

Thank you for the information fatherbushido!

Note: See TracTickets for help on using tickets.