Opened 4 years ago

Closed 4 years ago

#5030 closed defect (fixed)

OOS, serialization of NaN

Reported by: temple Owned by: temple
Priority: Release Blocker Milestone: Alpha 23
Component: UI & Simulation Keywords:
Cc: Patch:

Description (last modified by temple)

Reproduce by playing multiplayer game, have a building selected by one player, the other moves so that he's within range then moves out of range, and it's oos.

Attachments (1)

oos.zip (248.0 KB ) - added by temple 4 years ago.
example oos with lots of entities at the bottom that probably shouldn't be there

Download all attachments as: .zip

Change History (6)

by temple, 4 years ago

Attachment: oos.zip added

example oos with lots of entities at the bottom that probably shouldn't be there

comment:1 by temple, 4 years ago

Summary: oos, local entities serialized?OOS, serialization of NaN

This seems to come from r21121 where NaN is serialized (in Mirage, if no repairers then buildTime.timeRemaining = 0/0 = NaN). Somehow the GUI can change this to -NaN which is serialized differently (00 00 00 00 00 00 f8 7f versus 00 00 00 00 00 00 f8 ff).

comment:2 by temple, 4 years ago

Description: modified (diff)

comment:3 by temple, 4 years ago

(Ignore the first comment, that's irrelevant.)

comment:4 by temple, 4 years ago

Dupe of #1879, patch for this specific case at Phab:D1296.

comment:5 by temple, 4 years ago

Owner: set to temple
Resolution: fixed
Status: newclosed

In 21231:

Avoid NaN in Foundation and Repairable

Differential Revision: https://code.wildfiregames.com/D1296
Reviewed by: elexis
Comments by: bb, mimo
Fixes: #5030
Refs: #1879

Note: See TracTickets for help on using tickets.