Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5208 closed defect (duplicate)

replays not working

Reported by: barho0om_55 Owned by:
Priority: Release Blocker Milestone:
Component: Core engine Keywords:
Cc: Patch:

Description

so i played a game yesterday and there were a pro player playing with me so i decided to watch how he played , but i didn't find the replay of that game , and many other replays were missing , i asked my friend if he had the replay but he checked and had the same problem , and said that he only have one replay shown in 0 a d while we played on the new alpha 23 a lot matches. thank u

Attachments (1)

0.0.23.rar (624.2 KB ) - added by barho0om_55 2 years ago.
my replays in alpha 23

Download all attachments as: .zip

Change History (5)

by barho0om_55, 2 years ago

Attachment: 0.0.23.rar added

my replays in alpha 23

comment:1 by barho0om_55, 2 years ago

i tried to reinstall the game but no solution so far

comment:2 by temple, 2 years ago

You might have done Single Player -> Replays instead of Multiplayer -> Replays.

Alternatively, in the replay menu change the selection in the first dropdown in the top right: the choices are "Single- and Multiplayer", "Single Player", and "Multiplayer".

comment:3 by elexis, 2 years ago

Keywords: replays removed
Milestone: Alpha 23
Resolution: duplicate
Status: newclosed

I think you're looking for replays of rejoined games. Those aren't supported (maybe yet).

You can check by opening commands.txt with a text editor and see if it starts at turn 0. If it doesn't then the first part of the game until that turn is not saved in the replay (that's the part missing in the code).

I guess that's because player disconnects on gamestart are common in alpha 23. But we will release alpha 23 with that and few other bugs fixed in this or next week.

So I'm calling that a duplicate of #5163 and #3963.

comment:4 by elexis, 2 years ago

Also if you really want to see the replay, you can stitch together the two commands.txt files where the turns are missing.

Edit: Though I suppose the host always has the full replay...

Last edited 2 years ago by elexis (previous) (diff)
Note: See TracTickets for help on using tickets.