Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#5370 closed defect (invalid)

Tutorial will not advance past one point

Reported by: Bill Waggoner Owned by:
Priority: Nice to Have Milestone:
Component: UI & Simulation Keywords:
Cc: Patch:

Description

I did not follow the instructions exactly in the tutorial when it came to gathering stone and metal and although my soldiers were gathering the stone and metal I could not advance because I neglected to tell some of them to deposit their previous gatherings first.

I feel like there should be a "Proceed" button to use if the task is essentially complete but not detected by the tutorial engine.

I am running 23b, thanks for the update!

Change History (6)

comment:1 by Imarok, 22 months ago

Could you upload a reply where the bug happens?

comment:2 by Bill Waggoner, 22 months ago

I thought I described it above. It's after the Farm is created and the tutorial has you start gathering Stone and Metal with the Soldiers. I was a little quick in assigning the tasks and the first batch were assigned to gather Stone before I read that I should queue delivering the Wood they had already gathered to the Civic Center before gathering Stone. So the Wood they had in their arms was lost and the tutorial would not continue.

In general I think that there should be a way to tell the tutorial to continue to the next step whether or not it has detected the step's completion. Of course this may lead to difficulty later if a key task was not completed correctly but in my case I don't think continuing would have caused a problem, I had Soldiers gathering Metal and Stone and had only lost the bit of Wood that they had gathered but not delivered yet.

If that doesn't describe it well enough then please let me know and I'll try again.

comment:3 by Bill Waggoner, 22 months ago

Let me take some time to figure out where and what triggers the problem. I'll play with the tutorial over the next few days and see what I can find.

comment:4 by Bill Waggoner, 21 months ago

I have been unable to reproduce this so it can be closed.

comment:5 by Bill Waggoner, 21 months ago

Resolution: invalid
Status: newclosed

comment:6 by elexis, 21 months ago

Milestone: Backlog
Note: See TracTickets for help on using tickets.