Opened 11 months ago

Closed 11 months ago

Last modified 9 months ago

#5477 closed defect (fixed)

Rallypoint gather-orders result in the wrong resource location being gathered from

Reported by: elexis Owned by: wraitii
Priority: Release Blocker Milestone: Alpha 24
Component: Simulation Keywords: regression
Cc: Patch: Phab:D2034

Description

Steps to reproduce:

  1. Build a storehouse in a forest
  2. Set the CC rallypoint to a tree near that storehouse
  3. Train some units

Expected result:

  • Units gather near that desired location and subsequently use that storehouse to dropoff

Observed result:

  • Units gather at a location that is near the place where they were trained but far away from the intended location (thus not benefitting from the storehouse, taking long return-resource tours).

The bug was observed at least as soon as June 24th 2019 (see below) and at latest with r22426.

This bug is demonstrated here: https://youtu.be/uqHzawvxhO8?t=107 1:20 the rallypoint is set to gathering near the storehouse at the right side 1:40 the trained woman goes to gather at a forest on the left side where there is no storehouse

Change History (4)

comment:1 Changed 11 months ago by wraitii

Reproduced. The reason is that rP22342 switched units to GATHERING right away, which changed behaviour in ways I didn't anticipate.

Fixed in D2034

comment:2 Changed 11 months ago by elexis

Milestone: BacklogAlpha 24
Patch: Phab:D2034

comment:3 Changed 11 months ago by wraitii

Owner: set to wraitii
Resolution: fixed
Status: newclosed

In 22428:

Return Gathering to A23 behaviour - Make units try to gather near the target resource's position instead of their position.

Units were incorrectly looking at resources near their position following rP22342.

Fixes #5477.

Differential Revision: https://code.wildfiregames.com/D2034

comment:4 Changed 9 months ago by elexis

Keywords: regression added
Note: See TracTickets for help on using tickets.