Opened 15 months ago

Closed 14 months ago

Last modified 13 months ago

#5478 closed defect (fixed)

Ranged cavalry hunting results in idling in INDIVIDUAL.COMBAT.APPROACHING

Reported by: elexis Owned by:
Priority: Release Blocker Milestone: Alpha 24
Component: Simulation Keywords: regression
Cc: Patch: Phab:D2035, Phab:rP22367

Description

Bug observed with r22421 and r22426.

Steps to reproduce:

  1. Start with britons
  2. Select the skirmisher cavalry unit
  3. Gather order against a deer

Observed result:

  • Unit walks up to the deer attack range, enters INDIVIDUAL.COMBAT.APPROACHING and then doesn't do anything

Attachments (1)

commands.txt (5.7 KB ) - added by wraitii 15 months ago.
Reproduction on rp22426

Download all attachments as: .zip

Change History (6)

by wraitii, 15 months ago

Attachment: commands.txt added

Reproduction on rp22426

comment:1 by wraitii, 15 months ago

This isn't actually always a duplicated of #5479 like I initially thought. What happens is that the unit is ordered to move to the attack range, which uses a parabolic something formula. But the range check uses another formula... So they don't coincide. Further - these ranges depend on the height difference between the two units, which changes over time.

This didn't happen in A23 because COMBAT.APPROACHING called MoveToTargetAttackingRange if we weren't in range, which seems sensible given this problem. This might have been on purpose - there's no trace of it in the ticket or the commit, but it's been added then.

comment:2 by elexis, 15 months ago

Milestone: BacklogAlpha 24
Patch: Phab:D2035

comment:3 by wraitii, 15 months ago

This has been fixed by Phab:D2035 for the height difference, and by multiple other diffs for more general chasing behaviour such as Phab:rP22367

comment:4 by wraitii, 14 months ago

Patch: Phab:D2035Phab:D2035, Phab:rP22367
Resolution: fixed
Status: newclosed

Fixed for the specific bug, and fixed in general later on.

comment:5 by elexis, 13 months ago

Keywords: regression added
Note: See TracTickets for help on using tickets.