Opened 2 weeks ago

Closed 7 days ago

#5579 closed defect (fixed)

Unit building without build animation

Reported by: elexis Owned by:
Priority: Must Have Milestone: Alpha 24
Component: Simulation Keywords: regression
Cc: Patch:

Description

In this replay with r22829 at 55 seconds, Freagarach had a unit building a storehouse, but that that unit did not play the build animation.

Attachments (2)

commands.txt (769.7 KB) - added by elexis 2 weeks ago.
unit.jpg (1.5 MB) - added by elexis 2 weeks ago.

Change History (8)

Changed 2 weeks ago by elexis

Attachment: commands.txt added

Changed 2 weeks ago by elexis

Attachment: unit.jpg added

comment:1 Changed 2 weeks ago by Freagarach

I've done some testing, it seems it only occurs with the athenian hoplite whilst carrying resources. Easy to reproduce:

  • Start a game as Athenians,
  • Build a structure with a hoplite (normal building animation),
  • Let the hoplite gather something (carry at least 1 resource),
  • Finish the structure with the hoplite (no building animation).

Furthermore, it not only fails to display the build animation, also the gather animation is not shown when tasked to a resource again.

comment:2 Changed 2 weeks ago by elexis

Which sounds like a bug with the animation, but the animation is correctly playing if there are no resources.

Since it wasn't observed with other units so far, it sounds like a template bug?!

comment:3 Changed 2 weeks ago by stanislas69

The only difference I see between this unit and any other unit is that

  • It's a hoplite (hence has custom default animations) It might affect other greek civs.
  • The carry animations are not separated from the rest of the animations ,(wraitii told me there is no influence but that might be it)

Here is an example with the two groups splitting animations

Here are the files (A B E variants)

Here are the variants used (It's using the same build variant as everyone else and props are reset there so likely not it)

So either it's the fact animations are not split or something broke in UnitAI

comment:4 Changed 2 weeks ago by wraitii

This is most likely a template issue indeed. I think to fix this one needs to group the idle/walk/run overloads in the same group and the others in the other group, as done on the archer.

I'm not sure where I've said there was no influence, I'm pretty sure that's it.

comment:5 Changed 2 weeks ago by stanislas69

Can't remember was on IRC I think or over Phab. Can't find it easily on Phab and searching logs on irclogs on a phone is painful XD. Doesn't matter much as long as it's fixed :D

comment:6 Changed 7 days ago by Freagarach

Resolution: fixed
Status: newclosed

Fixed by rP22839.

Note: See TracTickets for help on using tickets.