Opened 5 months ago

Closed 5 months ago

#5922 closed defect (fixed)

View rotation of doom

Reported by: Imarok Owned by: wraitii
Priority: Release Blocker Milestone: Alpha 24
Component: UI – In-game Keywords:
Cc: Patch:

Description (last modified by Langbart)

Hold Ctrl+A or Ctrl+D.

Release the keys, but Ctrl first.

You will now continue to rotate till the heat death of the universe. This is persistent if you start a new game.

Happened on rP24637.

Not reproducible on A23.

Change History (15)

comment:1 by Imarok, 5 months ago

Description: modified (diff)

comment:2 by Imarok, 5 months ago

Optimus could reproduce on r24512

comment:3 by Imarok, 5 months ago

Caused by Phab:rP24215

comment:4 by Langbart, 5 months ago

start rotating

  1. ClockWise (cw) press ctrl and keep pressing A, lift your finger from ctrl first
  2. CounterClockWise (ccw) press ctrl and keep pressing D, lift your finger from ctrl first

stop rotating

  1. ClockWise (cw) keep ctrl pressed and tap A or just tap Q (without ctrl)
  2. CounterClockWise (ccw) keep ctrl pressed and tap D or just tap E (without ctrl)
Last edited 5 months ago by Langbart (previous) (diff)

comment:5 by s0600204, 5 months ago

To really have fun, disable the camera restrictions (via Alt+D) then tilt the camera with Ctrl+W or Ctrl+S. Now you can spin endlessly in two axis at once! :P

comment:6 by Freagarach, 5 months ago

Description: modified (diff)
Milestone: BacklogAlpha 24

comment:7 by wraitii, 5 months ago

This is definitely reproducible on A23 :P

Edit: I'm confused how I got that to repro using Super & Space, because it does seem like a new bug

Last edited 5 months ago by wraitii (previous) (diff)

in reply to:  7 comment:8 by OptimusShepard, 5 months ago

Replying to wraitii:

This is definitely reproducible on A23 :P

Can't reproduce for A23b.

comment:10 by wraitii, 5 months ago

Owner: set to wraitii
Resolution: fixed
Status: newclosed

In 24645:

Fix hotkeys not releasing properly.

rP24215 changed hotkeys to use scancode, but didn't change g_keys to reflect that, and this could break hotkey release.
This fixes that by explicitly using scancodes. Note that we might want a g_keys map in the future, but it seems un-necessary at the moment.

Also remove the last remnants of 'negated' hotkeys, which were disabled following rP15980.

Tested By: OptimusShepard

Fixes #5922

Differential Revision: https://code.wildfiregames.com/D3379

comment:11 by Langbart, 5 months ago

Resolution: fixed
Status: closedreopened
  • Pressing ctrl+D → release Ctrl → release D disables mouse orders (e.g. selecting units)
  • Pressing ctrl → tap D → release ctrl enables mouse orders again

Imarok could reproduce the error

comment:12 by Langbart, 5 months ago

Description: modified (diff)

comment:13 by Freagarach, 5 months ago

(Probably a new issue though.)

comment:14 by Langbart, 5 months ago

Description: modified (diff)

comment:15 by Langbart, 5 months ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.