Opened 2 months ago

Closed 2 months ago

#6250 closed defect (fixed)

PetraAI produces too much siege and ships.

Reported by: stanislas69 Owned by: Freagarach
Priority: Release Blocker Milestone: Alpha 25
Component: AI Keywords: regression
Cc: Freagarach, Angen Patch: Phab:D4184; Phab:D4193

Description (last modified by Freagarach)

See https://wildfiregames.com/forum/topic/45178-a25-svn-version-25810-not-playable/. Probably introduced in r25584.

  • She constructs a lot of siege without using it. (Uses most of it after r25826.)
  • She constructs way too much ships without using them. (Fixed in r25828.)

For the first point, it seems that a lot of attack plans are present, since AttackPlan.addSiegeUnits is called quite a lot, even though Siege is constructed.

The second point was the result of ships having class Ranged and thus PetraAI training them when asked to train Ranged units. Fixed by trying to train Infantry+Ranged.

Change History (10)

comment:1 by stanislas69, 2 months ago

Milestone: BacklogAlpha 25
Priority: Should HaveRelease Blocker

comment:2 by Angen, 2 months ago

Component: Core engineAI

comment:3 by Angen, 2 months ago

Owner: set to Freagarach

comment:4 by Freagarach, 2 months ago

In 25826:

(Partly) Fix PetraAI building a lot of siege and not using it.

Following r25584 / rP25584.
The used classes for adding siege were wrong.

Reported in https://wildfiregames.com/forum/topic/45178-a25-svn-version-25810-not-playable/.
Differential revision: https://code.wildfiregames.com/D4184
Refs. #6250 by (partly) fixing the siege case.
Reviewed by: @Angen

comment:5 by Freagarach, 2 months ago

Keywords: regression added
Milestone: Alpha 25Alpha 26

Pushing the rest of te ticket back to the next cycle.

comment:6 by Angen, 2 months ago

Cc: Angen added

comment:7 by Freagarach, 2 months ago

Description: modified (diff)
Patch: Phab:D4184Phab:D4184; Phab:D4193

comment:8 by Freagarach, 2 months ago

In 25828:

Fix PetraAI constructing ships as ordinary units.

Since r25584 / rP25584 PetraAI constructed many ships (and cavalry) because they have the "Ranged" class and we didn't check for "Infantry" anymore when training workers.

Basically a patch by: @Angen
Differential revision: https://code.wildfiregames.com/D4193
Reviewed by: @Angen
Refs. #6250 by fixing the ships case.
Fixes the concern on r25584 / rP25584.

comment:9 by Freagarach, 2 months ago

Description: modified (diff)
Priority: Release BlockerShould Have

Decreasing priority since PetraAI works as intended again. She just makes plenty of siege.

comment:10 by Freagarach, 2 months ago

Milestone: Alpha 26Alpha 25
Priority: Should HaveRelease Blocker
Resolution: fixed
Status: newclosed

Actually fixed in the two mentioned commits. The plenty of siege is a feature. ;)

If it is found that she indeed produces too much siege equipment, we can create a ticket for that since it existed probably in earlier alphas already. I'm closing this as fixed since the points mentioned and fixed were caused by r25584.

Note: See TracTickets for help on using tickets.