Opened 7 months ago

Closed 5 months ago

#6444 closed defect (fixed)

Some maps are broken.

Reported by: Freagarach Owned by: Freagarach
Priority: Release Blocker Milestone: Alpha 26
Component: Maps Keywords: regression
Cc: Patch:

Description

Including:

  • Survival of the fittest.
  • Regicide games.

Introduced in r26298.

Change History (5)

comment:1 by Freagarach, 5 months ago

Owner: changed from Freagarach to smiley
Patch: Phab:D4486Phab:D4613
Status: assignednew

comment:2 by wraitii, 5 months ago

Patch: Phab:D4613Phab:D4613, Phab:D4630

comment:3 by wraitii, 5 months ago

In 26867:

Fix map errors from GetTemplate not being available in the sim

Follows rP26298. Fixes it by providing a convenience function in the component Manager that matches the API in the GUI / AI

Refs #6444

Differential Revision: https://code.wildfiregames.com/D4630

comment:4 by Freagarach, 5 months ago

Owner: changed from smiley to Freagarach
Patch: Phab:D4613, Phab:D4630

comment:5 by Freagarach, 5 months ago

Resolution: fixed
Status: newclosed

In r26872:

Fix maps after r26298 / rP26298.

Correctly fetch the civ from the player's Identity. Also remove the notions of the CivChanged message, since it was effectively deleted already.

Differential revision: ​https://code.wildfiregames.com/D4486
Reviewed by: @wraitii
Comments by: @bb, @Silier, @smiley, @Stan, @vladislavbelov
Fixes #6444

Note: See TracTickets for help on using tickets.