Opened 6 months ago

Closed 6 months ago

#6546 closed defect (fixed)

Shroud of Darkness (SoD) visible terrain and territory lines

Reported by: Langbart Owned by: Vladislav Belov
Priority: Should Have Milestone: Alpha 26
Component: Core engine Keywords:
Cc: Patch:

Description (last modified by Langbart)

An issue was reported via IRC 0ad-dev 28/May/22

07:09 < Freagarach_afk> No, that I see the terrain and territory lines in SoD.
07:11 < Freagarach_afk> It seems it depends on the map also.
07:11 < Freagarach_afk> With some terrains it is more visible.

GL ARB Smoothlos=true Add to surexpose to make it more visible. Before reveal map After reveal map

to reproduce

  • Switch to GL ARB backend
  • Restart the Game (Make Sure Smoothlos is on)
  • Open Acropolis bay,
  • move around and notice everything is black.
  • Open the dev overlay
  • Reveal Map, and hide it again.
  • move around and notice everything is still slightly visible.

bisect

Was likely triggered after the LOS changes. [26906]

Note: macOS - [26908] I could not reproduce the problem and only created the ticket so that it would not be forgotten. see comment:5:ticket:6546

possible solution

Revert the default setting for smoothlos back to false.

reproducible

Adding smoothlos = "true" to the user.cfg file and testing on older versions. The problem could be reproduced up to Alpha XVI - Patañjali [15148]. Below that I have not tested.

additional nit-pick

smoothlos was unintentionally removed from the options with [25581].
See IRC 0ad-dev 2/Jun/22/3/Jun/22

17:16 < Langbart> @tell wraitii was intended to remove smoothlos with changeset rP25581?
[...]
 07:16 < wraitii> @tell langbart: re rP25581, it looks like it wasn't, but I think vlad recently activated by default (asked him), so maybe the bug can now be seen as  'invalid'

It may or may not be added back into the options, that is at the judgement of the patch maker.

Attachments (3)

screenshot0018.png (86.8 KB ) - added by Stan‘ 6 months ago.
screenshot0022.png (442.9 KB ) - added by Stan‘ 6 months ago.
exp_cont.jpg (256.4 KB ) - added by Langbart 6 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 by Stan‘, 6 months ago

Description: modified (diff)

by Stan‘, 6 months ago

Attachment: screenshot0018.png added

by Stan‘, 6 months ago

Attachment: screenshot0022.png added

comment:2 by Stan‘, 6 months ago

Description: modified (diff)

comment:3 by Langbart, 6 months ago

Followed the instructions but can't reproduce the problem. Set the exposure high on the display, but everything is nice and black on my end.

comment:4 by Stan‘, 6 months ago

Better screen contrast on a mac screen maybe.

comment:5 by Langbart, 6 months ago

That's it. I can't see it in the active game window, but when I take a screenshot and play with the exposure and contrast, the problem becomes visible to me too.

by Langbart, 6 months ago

Attachment: exp_cont.jpg added

comment:6 by Langbart, 6 months ago

Description: modified (diff)

comment:7 by Langbart, 6 months ago

Description: modified (diff)

reproducible section added

comment:8 by Langbart, 6 months ago

Description: modified (diff)

nit-pick remark

comment:9 by Vladislav Belov, 6 months ago

Owner: set to Vladislav Belov
Resolution: fixed
Status: newclosed

In 26922:

Fixes LOS flickering because of float precision. Fixes #6546

Tested By: Langbart

Differential Revision: https://code.wildfiregames.com/D4684

Note: See TracTickets for help on using tickets.