Opened 6 months ago

Closed 6 months ago

#6569 closed defect (fixed)

Visibility issue with smoothlos in fast forward observer mode

Reported by: Langbart Owned by: Vladislav Belov
Priority: Release Blocker Milestone: Alpha 26
Component: Core engine Keywords:
Cc: Patch: Phab:D4700

Description (last modified by Langbart)

to reproduce

  • Default settings applied
  • Create a replay in which your unit establishes an outpost in the outskirts of your area.
  • View the replay, but at a minimum of 5x or even better 10x speed and set the view to that player.
    • Alternatively, you can start a game with delenda_est activated and set the game speed to 10x.
  • the visibility does not adjust (20x) or lags behind noticeable (5x), if you lower the speed below 2x it does work properly.
  • See GIF/image below for more clarity.

bisect

[26922]

workaround

Set smoothlos=false

reproducible

When watching in 20xfast-forward with smootlos=true in A25b, the visibility works correctly.

Attachments (2)

sommothlos_outpost.gif (366.2 KB ) - added by Langbart 6 months ago.
delenda_est.jpg (64.8 KB ) - added by Langbart 6 months ago.

Download all attachments as: .zip

Change History (7)

by Langbart, 6 months ago

Attachment: sommothlos_outpost.gif added

by Langbart, 6 months ago

Attachment: delenda_est.jpg added

comment:1 by Langbart, 6 months ago

Description: modified (diff)

bisecting

comment:2 by Langbart, 6 months ago

Priority: Should HaveRelease Blocker

milestone

[21:44:04] elexis #6569 sounds like graphical representation of LoS is only updated when a frame is rendered, but with 20x replay you might simulate one or more full simulation turns before a single frame is rendered. then if only LOS deltas are applied during the frame instead of the entire LoS, it would cause the reported bug
[21:44:26] elexis we had the same bug in dying breed, the solution is to update LoS / SoD in accordance with the simulation, not the GUI
[21:44:45] elexis or one accumulates all LoS updates acrodd simulation turns. (if thats even how the code works)
[...]
[21:49:34] elexis if my frame-dependency theory about #6569 is correct, then you get the bug the more often, the better the performance is, i.e. the less entities are on that map (since that way you can simulate more turns before the next frame is rendered. if my logic isnt flawed)
[21:50:13] elexis oh it is a regression, well then one could argue its an RB
[21:51:13] elexis maybe its related to timer_Time() precision

comment:3 by Langbart, 6 months ago

Owner: set to Vladislav Belov
Patch: D4700

adding patch

comment:4 by Langbart, 6 months ago

Patch: D4700Phab:D4700

Set the correct link

comment:5 by Vladislav Belov, 6 months ago

Resolution: fixed
Status: newclosed

In 26950:

Fixes same sequenced frames for LOS smooth textures. Fixes #6569

Tested By: Langbart

Differential Revision: https://code.wildfiregames.com/D4700

Note: See TracTickets for help on using tickets.