Changes between Version 424 and Version 425 of BuildInstructions


Ignore:
Timestamp:
May 14, 2022, 9:57:47 PM (6 weeks ago)
Author:
tim
Comment:

add instructions for slackware 15.0

Legend:

Unmodified
Added
Removed
Modified
  • BuildInstructions

    v424 v425  
    271271
    272272Use the 0ad-data and 0ad slackbuilds from https://slackbuilds.org/repository/14.2/games/0ad-data/ and https://slackbuilds.org/repository/14.2/games/0ad/ this is fine for v0.0.23b . Newer versions require gcc>=7 so you'll have to use slackware-current or wait till slackware 15.0 comes out if you want to try them out.
     273
     274'''''Slackware 15.0'''''
     275
     276If you've done the full install of Slackware, most of the [#Dependencies dependencies] are already installed. The other required dependencies you can build and install from the [https://slackbuilds.org/ Slackbuilds repo] using [https://sbopkg.org/ sbopkg]:
     277
     278 * enet
     279 * fmt
     280 * gloox
     281 * miniupnpc
     282 * wxGTK3 (which has it's own dependencies)
     283   * webkit2gtk (which requires)
     284     * bubblewrap
     285     * geoclue2
     286     * xdg-dbus-proxy
     287     * wpebackend-fdo (which requires)
     288       * libwpe
     289 * 0ad-data
     290
     291then build and install **0ad** with the {{{ ATLAS=enable }}} option for the map editor
    273292
    274293'''''Slackware-current'''''