Opened 5 years ago

Closed 5 years ago

#2332 closed defect (fixed)

Problem with the boar skeleton

Reported by: Itms Owned by: leper
Priority: Release Blocker Milestone: Alpha 16
Component: Art & Animation Keywords:
Cc: leper, wraitii Patch:

Description

I tried to play on Lorraine Plains and I get this JS error continuously : Model art/meshes/skeletal/boar is boned with unboned animation

When I move the camera, it sometimes disappears. It comes back for some camera positions, and not for others (there must be a boar somewhere but I don't see it). Roughly I get the message south of my CC, until I reach the river.

It may be related to [12757], given the commit message.

Attachments (1)

glitch.jpg (344.6 KB) - added by Itms 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by sanderd17

I got the same, but only after deleting the cache. So for anyone debugging it, and not finding a problem, delete the cache.

Also, as the cache is supposed to rebuild if something changed, that might be a different bug.

comment:2 Changed 5 years ago by sanderd17

Milestone: BacklogAlpha 16
Priority: Must HaveRelease Blocker

comment:3 Changed 5 years ago by Itms

The same bug appears in Atlas.

Additionally, I experience a problem with graphics when this error comes up, in full screen game (I can't do a screenshot there) and in Atlas : I attach an image.

Changed 5 years ago by Itms

Attachment: glitch.jpg added

comment:4 Changed 5 years ago by Ben Brian

Cc: leper wraitii added

comment:5 Changed 5 years ago by wraitii

I'm quite sure this can't happen in the release since caching fixes the issue… So this is not exactly a "Release Blocker".

comment:6 Changed 5 years ago by leper

Owner: set to leper
Resolution: fixed
Status: newclosed

In 14699:

Change hawk and boar skeletons so that the root identifiers are unique. Fixes #2332.
Also adjust the DAEs to fit the new identifiers.

Note: See TracTickets for help on using tickets.