Opened 20 months ago

Closed 17 months ago

Last modified 17 months ago

#3904 closed defect (fixed)

[PATCH] Mauryans Yudhpot ship garrison number limit number doesn't match unit description

Reported by: bugmenot Owned by: elexis
Priority: Should Have Milestone: Alpha 21
Component: UI & Simulation Keywords: patch
Cc: Patch:

Description

This is just a little problem I found on 0.20.

While playing with Mauryans, the Yudhpot (Medium Warship) description says that the ship can have a maximum of 30 garrisoned units, but actually it supports 40 units.

https://s21.postimg.org/u0zbi3q2f/mauryans_ship_garrison.jpg

Attachments (6)

3904.diff (4.1 KB) - added by fatherbushido 19 months ago.
tooltip.diff (27.4 KB) - added by fatherbushido 17 months ago.
tooltip.2.diff (27.5 KB) - added by fatherbushido 17 months ago.
thx elexis for the remarks
tooltip.3.diff (27.6 KB) - added by fatherbushido 17 months ago.
thx for 2nd batch of remarks
tooltip.4.diff (27.3 KB) - added by fatherbushido 17 months ago.
tooltip.5.diff (64.0 KB) - added by elexis 17 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 20 months ago by fatherbushido

The mauryan trirem have a specific GarrisonHolder like the brits or the gauls one. The tooltip which is showed is there parent one. The problem is perhaps a more general one (hardcoded numbers in tooltip).

Last edited 20 months ago by fatherbushido (previous) (diff)

Changed 19 months ago by fatherbushido

Attachment: 3904.diff added

comment:2 Changed 19 months ago by fatherbushido

It comes from r17882. I checked other templates which could have been affected.

comment:3 Changed 19 months ago by fatherbushido

Keywords: patch review added; Unit removed
Summary: Mauryans Yudhpot ship garrison number limit number doesn't match unit description[PATCH] Mauryans Yudhpot ship garrison number limit number doesn't match unit description

comment:4 Changed 19 months ago by elexis

Keywords: review removed
Milestone: BacklogAlpha 21
  • To fix the fundamentally broken mechanism of hardcoding numbers in tooltips, see #3972.
  • We should ask a native speaker if the "Garrison improves the strength" should be "Garrisoning improves the strength"
  • Alpha 20 showed that people are not aware of the fact that the number of units that shoot arrows is limited to 10. Since the tooltip says 13 arrows are shot at most, they will often garrison 13 units. While at it, the tooltip should clarify that while staying as short as possible.
  • The siege tower shoots only one arrow for every second unit. This should either be stated in the tooltip or be reverted to 1 arrow/unit and use the limit patch from r17882.

comment:5 Changed 19 months ago by fatherbushido

ref #3816

Changed 17 months ago by fatherbushido

Attachment: tooltip.diff added

comment:6 Changed 17 months ago by fatherbushido

Keywords: review added

Attached patch should solve that:

  • add a garrison and an arrow tooltip (so it only remains some stuff in the structure tree to do to fix #3816). They are displayed in construction panel (for cc, towers, fortress...) and in training panel (for siege tower and ships ie units with a buildingAI).
  • btw fix #4061
  • remove all (i hope) related numbers in templates

Changed 17 months ago by fatherbushido

Attachment: tooltip.2.diff added

thx elexis for the remarks

Changed 17 months ago by fatherbushido

Attachment: tooltip.3.diff added

thx for 2nd batch of remarks

Changed 17 months ago by fatherbushido

Attachment: tooltip.4.diff added

Changed 17 months ago by elexis

Attachment: tooltip.5.diff added

comment:7 Changed 17 months ago by elexis

Owner: set to elexis
Resolution: fixed
Status: newclosed

In 18455:

Garrison tooltips by fatherbushido.

Show how many units can be garrisoned, the number of arrows shot by default, per unit and limit, fixes #3816.
Thus remove a lot of hardcoded numbers in the translated strings and
correct a wrong number for the mauryan ship, fixes #3904.

comment:8 Changed 17 months ago by elexis

Keywords: review removed

Thanks, that tooltip was overdue, those strings had hurt.

Note: See TracTickets for help on using tickets.