Opened 3 years ago

Closed 3 months ago

#5255 closed defect (fixed)

FreeBSD porting patches

Reported by: Guido Falsi Owned by: Stan
Priority: Should Have Milestone: Alpha 24
Component: Build & Packages Keywords:
Cc: Patch: Phab:D1592, Phab:D1593, Phab:D1594, Phab:D2399

Description (last modified by Guido Falsi)

Hi,

While updating the FreeBSD port to Alpha 23 I encountered a few problems, especially on FreeBSD 12 (the development version) due to the newer version of clang.

I'm planning to send code reviews for the required patches, grouping them logically. I need some time to port them to the present subversion tree.

I'll track those reviews here for reference, if that's ok.

Change History (11)

comment:1 by Guido Falsi, 3 years ago

Created review for updates psutil patch:

https://code.wildfiregames.com/D1592

comment:2 by Guido Falsi, 3 years ago

Created review for patches required to work with newer clang (6.0.0 and higher):

https://code.wildfiregames.com/D1593

comment:3 by Guido Falsi, 3 years ago

Description: modified (diff)

comment:4 by Guido Falsi, 3 years ago

Created review to conditionalize use of MAP_NORESERVE, which is not known by FreeBSD mmap:

https://code.wildfiregames.com/D1594

comment:5 by Guido Falsi, 3 years ago

I'm also seeing this problem:

> ActorEditor 
Cannot open "../../../binaries/system/libAtlasUI.so"

Which is caused by this command during compilation:

c++ -o "../../../binaries/system/ActorEditor" obj/ActorEditor_Release/ActorEditor.o    -fstack-protector -L../../../binaries/system -L/usr/local/lib -Wl,--no-undefined -Wl,--as-needed -Wl,-z,relro -Wl,-rpath,/usr/local/lib/0ad  ../../../binaries/system/libAtlasObject.a ../../../binaries/system/libAtlasUI.so

I need to check, I'm almost sure that the final

../../../binaries/system/libAtlasUI.so

should be

-lAtlasUI.so

so that the rpath option would apply its magic.

I am trying to understand how to coerce the build system in doing things this way and test this theory. I'm open to suggestions.

Last edited 3 years ago by Guido Falsi (previous) (diff)

comment:6 by stanislas69, 3 years ago

Cc: Phab:D1592 Phab:D1593 Phab:D1594 added
Component: Non-game systemsBuild & Packages

Thanks for your work :) In case you didn't know we will make another release soonish because of GDPR and some annoying bugs. I'll see if I can get Itms to review those patches :) in the meantime you can set him as reviewer on Phabricator.

in reply to:  6 comment:7 by Guido Falsi, 3 years ago

Replying to stanislas69:

Thanks for your work :) In case you didn't know we will make another release soonish because of GDPR and some annoying bugs. I'll see if I can get Itms to review those patches :) in the meantime you can set him as reviewer on Phabricator.

I did set Itms as reviewer, thanks!

BTW any pointer on where to look to fix the ActorEditor problem would be appreciated, I'm digging into the premake lua files but can't really find what needs to be modified.

Last edited 3 years ago by Guido Falsi (previous) (diff)

comment:8 by elexis, 2 years ago

Cc: Phab:D1592 Phab:D1593 Phab:D1594 removed
Patch: Phab:D1592, Phab:D1593, Phab:D1594

comment:9 by elexis, 18 months ago

Patch: Phab:D1592, Phab:D1593, Phab:D1594Phab:D1592, Phab:D1593, Phab:D1594, Phab:D2399

comment:10 by Stan, 3 months ago

In 24666:

Fix some compilation issues on BSD

Tested by: @madpilot, @nephele
Refs: #5255

Differential Revision: https://code.wildfiregames.com/D3288

comment:11 by Stan, 3 months ago

Owner: set to Stan
Resolution: fixed
Status: newclosed

In 24704:

Fixes FreeBSD build on 12.2

  • Fix compiler warning with Clang
  • Fix usage of libiconv
  • Fix an incorrect SSE macro in NVTT for SSE

Patch by: @madpilot and Stan
Fixes: #5255
Differential Revision: https://code.wildfiregames.com/D3421

Note: See TracTickets for help on using tickets.