Opened 14 months ago

Closed 13 months ago

Last modified 11 months ago

#5480 closed defect (fixed)

Unit computed a path that makes it stuck, then ignores some but not all move orders

Reported by: elexis Owned by:
Priority: Release Blocker Milestone: Alpha 24
Component: Simulation Keywords: regression
Cc: Patch: Phab:D1907

Description

In this replay with r22426 a female (entityID 7084, F9 -> g_Selection.addList[7084];) was gathering, got stuck near a small stone mine and stopped moving. The woman received some move orders and changed the direction she was facing, but did not move. Some move orders later she did move.

Attachments (1)

commands.txt (12.7 KB ) - added by elexis 14 months ago.

Download all attachments as: .zip

Change History (5)

by elexis, 14 months ago

Attachment: commands.txt added

comment:1 by elexis, 14 months ago

Milestone: BacklogAlpha 24

comment:2 by wraitii, 13 months ago

Cannot reproduce the behaviour on the replay post D1907 - this appears to trigger a safety fallback case in PathResult but it works nowadays and the woman gets to build the first and second house, then follows other units.

comment:3 by wraitii, 13 months ago

Patch: Phab:D1907
Resolution: fixed
Status: newclosed

Fixed by Phab:D1907

comment:4 by elexis, 11 months ago

Keywords: regression added
Note: See TracTickets for help on using tickets.