Opened 5 months ago

Closed 5 months ago

#6506 closed defect (fixed)

Mouse cursor - selection bug

Reported by: Langbart Owned by:
Priority: Must Have Milestone: Alpha 26
Component: Core engine Keywords:
Cc: Patch: Phab:D4624

Description

Youtuber Alistair Findlay outlines a bug on the current development version.

issue

Check the video at 2min:25secs!

When he clicks, the mouse moves one pixel to the side.

Quote

It probably happens [...] at 1080p maybe 4-5% of the time, barely noticeable. At 1440p it happens 20% of the time, at 4k it happens practically half the time.

(I could not reproduce the problem on macOS, the ticket was created before the problem fades into oblivion.)

Attachments (2)

selection_bug.gif (144.5 KB ) - added by Langbart 5 months ago.
Screenshot from 2022-04-24 12-56-34.png (1.1 MB ) - added by Alistair_Findlay 5 months ago.
Select building?

Download all attachments as: .zip

Change History (11)

by Langbart, 5 months ago

Attachment: selection_bug.gif added

comment:1 by Vladislav Belov, 5 months ago

When he clicks, the mouse moves one pixel to the side.

It highly depends on mouse and how sensitive it is. I've never encounter it on 2K and 4K resolutions.

We might calculate a minimal box size to start selecting, but it also depends on screen resolution, pixel density and mouse sensitivity.

So I might suggest to add an option to set the minimal box size in pixels.

Last edited 5 months ago by Vladislav Belov (previous) (diff)

comment:2 by Vladislav Belov, 5 months ago

It's a bit unclear, is it a mouse movement or a cursor moves even the mouse is absolutely motionless?

comment:3 by Langbart, 5 months ago

Priority: Should HaveRelease Blocker
[23:12:58] elexis "half the time you want to select something, you dont" is release blocker material on my watch

by Alistair_Findlay, 5 months ago

Select building?

in reply to:  2 ; comment:4 by Alistair_Findlay, 5 months ago

Replying to Vladislav Belov:

It's a bit unclear, is it a mouse movement or a cursor moves even the mouse is absolutely motionless?

The mouse does move, my mouse has massive feet and a high dpi, the motion of my finger on the click button sometimes causes the mouse to move a tiny bit. That tiny bit doesn't equal a pixel at lower resolutions, but at 4k it's a problem. It's also because I start moving my mouse after I lift my finger off the mouse click, but the mechanical click takes an extra few milliseconds to disengage, during that time i have been moving my mouse to another area.

So I might suggest to add an option to set the minimal box size in pixels.

This seems about right, if a box is made on top of a selectable object, it shouldn't matter how big or small the box is, it should still select the object.

The box in the above gif, maybe should select the building underneath it.

Select building?

At the very least, a box this size should DEFINITELY select the building.

Last edited 5 months ago by Alistair_Findlay (previous) (diff)

in reply to:  4 ; comment:5 by Vladislav Belov, 5 months ago

Replying to Alistair_Findlay:

The mouse does move, my mouse has massive feet and a high dpi, the motion of my finger on the click button sometimes causes the mouse to move a tiny bit. That tiny bit doesn't equal a pixel at lower resolutions, but at 4k it's a problem. It's also because I start moving my mouse after I lift my finger off the mouse click, but the mechanical click takes an extra few milliseconds to disengage, during that time i have been moving my mouse to another area.

Thanks for making it clear!

So I might suggest to add an option to set the minimal box size in pixels.

This seems about right.

That's easy to add.

if a box is made on top of a selectable object, it shouldn't matter how big or small the box is, it should still select the object.

The box in the above gif, maybe should select the building underneath it.

At the very least, a box this size should DEFINITELY select the building.

That part is much more tricky. We select an entity only if the selection box covers the entity origin. Selecting by bounding box doesn't work well a for a box selection because it selects too much.

comment:6 by Silier, 5 months ago

Patch: Phab:D4624

comment:7 by Alistair_Findlay, 5 months ago

D4624 fixes this for me, it moves a variable to the default.cfg that the user can then edit. I have found that setting it to 75 has a %99 "issue rectification level" for 1440p, and the same "IRL" at 100 for 2160p.

comment:8 by Silier, 5 months ago

Priority: Release BlockerMust Have

In 26843
Add Mouse drag to options

Allow to modify pixel distance when mouse input is detected as drag e.g. for selection box.

Differential revision: Phab:D4624
Refs: #6506
Comments by: @vladislavbelov @Freagarach
Tested by: @psypherium

Last edited 5 months ago by Silier (previous) (diff)

in reply to:  5 comment:9 by Freagarach, 5 months ago

Resolution: fixed
Status: newclosed

Replying to Vladislav Belov:

Replying to Alistair_Findlay:

At the very least, a box this size should DEFINITELY select the building.

That part is much more tricky. We select an entity only if the selection box covers the entity origin. Selecting by bounding box doesn't work well a for a box selection because it selects too much.

One can make a separate ticket for this ^ request.

Note: See TracTickets for help on using tickets.