Opened 6 months ago

Closed 4 months ago

#6893 closed defect (fixed)

PetraAI tries to research Wicker Basket and Ahimsa

Reported by: phosit Owned by: phosit
Priority: Release Blocker Milestone: Alpha 27
Component: AI Keywords:
Cc: Patch: Phab:D5238

Description

When PetraAI plays as the Mauryas PetraAI tries to research Wicker Basket and Ahimsa.

Wicker Basket and Ahimsa are a "technology pair", a player can research only one of them.

This ticket is only about the Wicker Basket and Ahimsa pair. Propably PetraAI also can't handle other technology pairs.

The defect is present since the technology pair got introduced in [27958].

I'll attach a replay but it's easy to reproduce with ./binaries/system/pyrogenesis --autostart=random/mainland --autostart-ai=1:petra --autostart-civ=1:maur.

Attachments (1)

commands.txt (14.1 KB ) - added by phosit 6 months ago.
Replay

Download all attachments as: .zip

Change History (4)

by phosit, 6 months ago

Attachment: commands.txt added

Replay

comment:1 by wowgetoffyourcellphone, 5 months ago

I have noticed playing Delenda Est that indeed the AI may have trouble with paired techs. I might investigate further to give further credence to it. 

comment:2 by phosit, 4 months ago

Owner: set to phosit
Patch: Phab:D5238

comment:3 by phosit, 4 months ago

Resolution: fixed
Status: newclosed

fixed in [28026]

Note: See TracTickets for help on using tickets.