Changes between Version 8 and Version 9 of Basic3DImplementation


Ignore:
Timestamp:
Jul 22, 2017, 10:39:42 PM (18 months ago)
Author:
leper
Comment:

Host images directly on trac, instead of relying on external image hosts that might just stop providing that service. web.archive.org is quite useful.

Legend:

Unmodified
Added
Removed
Modified
  • Basic3DImplementation

    v8 v9  
    55
    66Your final result will look something like this:[[BR]][[BR]]
    7 [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/atlasfinal.gif)]]
     7[[Image(atlasfinal.gif)]]
    88
    99== Requirements ==
     
    8484 Open the texture file in Gimp by going to File > Open... and then selecting the image downloaded from burningwell.org. Once opened the editing window should look like this:[[BR]]
    8585
    86  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/textureopened.gif)]][[BR]]
     86 [[Image(textureopened.gif)]][[BR]]
    8787 
    8888 * '''STEP 4 -''' Now we are going to resize the texture so that it is 128x128 pixels. To do this, go to '''Image > Scale Image''' and change the Height value to 128 pixels. Make sure the Height and Width dimensions are locked (this changes the width value to 171px) like in the image below:[[BR]]
    8989 
    90  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/texturescale.gif)]][[BR]]
     90 [[Image(texturescale.gif)]][[BR]]
    9191 Select 'Scale' button to perform the scale[[BR]]
    9292 
    9393 * '''STEP 5 -''' We're now going to edit the canvas to make the texture 128x128. Go to '''Image > Canvas Size...''' and there change the Width to 128px. The Offset can also be set similar to how I've done it below:[[BR]]
    9494
    95  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/texturecanvas.gif)]][[BR]]
     95 [[Image(texturecanvas.gif)]][[BR]]
    9696 
    9797 Select 'Resize' button to perform the resize to 128x128[[BR]]
     
    111111 * '''STEP 2 -''' We're going to use the cube that appears by default in Blenders 3D View window:[[BR]]
    112112 
    113  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/blenderstart.gif)]][[BR]]
     113 [[Image(blenderstart.gif)]][[BR]]
    114114 
    115115 The first thing we're therefore going to do is change from  'Object Mode' to 'Edit Mode':[[BR]]
    116116 
    117  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/blendereditmode.gif)]][[BR]]
     117 [[Image(blendereditmode.gif)]][[BR]]
    118118 
    119119 * '''STEP 3 -''' Once in edit mode go to '''Mesh > UV Unwrap... > Unwrap''':[[BR]]
    120120 
    121  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/blenderuvunwrap.gif)]][[BR]]
     121 [[Image(blenderuvunwrap.gif)]][[BR]]
    122122
    123123 * '''STEP 4 -''' Surprisingly that's all we need to do in this very simple example. So now we can export the 3D model file by going back into 'Object Mode', selecting the cube, and going to '''File > Export > COLLADA (.dae)''':[[BR]]
    124124 
    125  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/blenderexport.gif)]][[BR]]
     125 [[Image(blenderexport.gif)]][[BR]]
    126126 
    127127 * '''STEP 5 -''' In the export window that opens up, select 'Export only selected':[[BR]]
    128128
    129  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/blenderselectedonly.gif)]][[BR]]
     129 [[Image(blenderselectedonly.gif)]][[BR]]
    130130 
    131131 * '''STEP 6 -''' Change the filename to wrld_crate_test.dae and then click 'Export COLLADA':[[BR]]
    132132
    133  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/blendersave.gif)]][[BR]]
     133 [[Image(blendersave.gif)]][[BR]]
    134134 
    135135 * '''STEP 7 -''' Move the DAE file to the following location: `binaries\data\mods\public\art\meshes\props` (see [wiki:Mod_Layout mod layout] for details)
     
    142142 * '''STEP 1 -''' Run 0 A.D. and in the menu select '''Tools & Options > Scenario Editor''':[[BR]]
    143143
    144  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/scenarioeditor.gif)]][[BR]]
     144 [[Image(scenarioeditor.gif)]][[BR]]
    145145
    146146 * '''STEP 2 -''' Select the [wiki:Atlas_Manual_Object_Tab Object tab]:[[BR]]
    147147
    148  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/atlasobject.gif)]][[BR]]
     148 [[Image(atlasobject.gif)]][[BR]]
    149149 
    150150 * '''STEP 3 -''' Select Actors(All) in the dropdown to view actor objects instead of [wiki:Entity entities] (that requires additional templating):[[BR]]
    151151
    152  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/atlasactorsallt.gif)]][[BR]]
     152 [[Image(atlasactorsallt.gif)]][[BR]]
    153153 
    154154 * '''STEP 4 -''' In the Filter field type 'crate_test' to find the actor file we created earlier:[[BR]]
    155155
    156  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/atlasfilter.gif)]][[BR]]
     156 [[Image(atlasfilter.gif)]][[BR]]
    157157 
    158158 * '''STEP 5 -''' Select the actor file in the list, and then click on 'Switch to Actor Viewer' to view the object in [wiki:Atlas_Manual_Object_Tab#TheActorViewer Actor Viewer]:[[BR]]
    159159
    160  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/atlasactorviewer.gif)]][[BR]]
     160 [[Image(atlasactorviewer.gif)]][[BR]]
    161161 
    162162 * '''STEP 6 -''' The finished object should look like this in Actor Viewer:[[BR]]
    163163
    164  [[Image(http://i173.photobucket.com/albums/w73/purepics/0AD/atlasfinal.gif)]][[BR]]
     164 [[Image(atlasfinal.gif)]][[BR]]
    165165
    166166== Common Exporting Errors ==