Opened 7 years ago

Closed 7 years ago

#1531 closed defect (duplicate)

It is impossible to replace wall towers

Reported by: gudo Owned by:
Priority: Should Have Milestone:
Component: UI & Simulation Keywords: wall
Cc: Patch:

Description

If a wall tower should be destroyed, it is currently impossible to replace the tower without first destroying all adjacent, connecting wall pieces.

It seems that along with ticket #1529, there is still some work to be done when checking wether or not a wall foundation is truly blocked.

Change History (5)

comment:1 Changed 7 years ago by gudo

Component: Core engineUI & Simulation

comment:2 Changed 7 years ago by O.Davoodi

In nearly all games when a walltower is destroyed, the nearby wall segments are also destroyed. Should we take this approach?

comment:3 Changed 7 years ago by Kieran P

Milestone: BacklogAlpha 12

comment:4 Changed 7 years ago by fabio

This looks a duplicate of third point of #1566 (this is older but there are more infos in #1566).

comment:5 Changed 7 years ago by fabio

Milestone: Alpha 12
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.