Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#3155 closed enhancement (wontfix)

[PATCH] Allow the Developers Overlay only with cheats enabled

Reported by: elexis Owned by:
Priority: Should Have Milestone:
Component: UI & Simulation Keywords:
Cc: Patch:

Description

Since the developers overlay allows one to change the perspective and control nearly every unit on the map, the tool shouldn't be available without cheats being actived.

I've seen this function being used for different purposes by a bunch of players. Also who uses WASD to scroll and Alt+Doubleclick to select all units of one kind can open that overlay by accident, especially when experiencing #2809.

The patch in #614 implemented that opening the developers overlay causes a chat message to be shown on all clients, but it still allows cheating without cheats being enabled.

The patch that I attached fixes this issue in the GUI only.

Attachments (1)

developer-overlay-only-with-cheats.patch (916 bytes) - added by elexis 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by elexis

comment:1 Changed 4 years ago by sanderd17

I don't think this is such a good idea. The game is still in alpha phase, so the focus is on development rather than play. Limiting access to the developer overlay might hinder deployment.

Maybe, you could bring up a gui popup instead, asking if the player really wants to see the developer overlay. That way, on an accidental alt+d, the player can choose to not open the dev overlay, and no chat will be send.

comment:2 Changed 4 years ago by Ben Brian

I agree with sanderd17, it's far more important to have fast access to those debugging functions now than to prevent every possible cheat. Even a popup is an obstacle to that. If someone wants to cheat that badly, they can modify the GUI to avoid these measures anyway.

I think the chat message is enough, though chat isn't logged currently, so it could be missed.

comment:3 Changed 4 years ago by elexis

There is not a single problem with this developer overlay, there are many individual problems of varying degree of severity.

Happens frequently: (1) Some people open this by accident ( (2) and are accused of cheating thereafter) (3) some open it and close it immediately before they could issue any commands

Seen multiple times: (4) some people open it to reduce the lag by deleting offline players (5) some open it and don't use it at all but state that they are the best hax0rs (6) trolling by moving players units (7) revealing the map to explain the situation to the enemy (usually in never-ending games)

Never seen this happen: (6) real cheating to win a game

I have 30 commands.txt files, where observers issued commands (I used it in less than 10 debug sessions) and this is just the number where people were actively using this tool as spectator, not counting the amount of innocent openings of the developers overlay, where people are accused of cheating. Also banning people for using a feature is less constructive than patching this I think. From the players perspective, there is no reason this should be allowed without cheats enabled.

But I also agree that developers should have all the tools at hand they need.

Consider that the persist match settings saves the "cheats enabled" option, so that the developer who rarely plays in the multiplayer lobby will have this developer overlay always available by default (if started with cheats once). Also consider that cheats are enabled by default in all singleplayer matches and that currently ranked games can't be debugged with the developer overlay.

Im not sure if the current autostart allows to activate cheats for multiplayer matches though.

Last edited 4 years ago by elexis (previous) (diff)

comment:4 Changed 4 years ago by Ben Brian

Keywords: review removed
Milestone: Alpha 19
Resolution: wontfix
Status: newclosed

I'm not only talking about developers testing the game. On a number of occasions, it has been necessary to have a user access the developer overlay to look at things like the selection state, that can't be known any other way, and the other options can be of similar value when submitting good bug reports (why should e.g. reveal map not be allowed to show a bug?). Many bugs aren't easy to reproduce or the steps aren't clear to the user, by then it's too late to change the match settings and it may not help to restart the game.

comment:5 in reply to:  description Changed 4 years ago by Ben Brian

In short, there's no clear line between testers and players when the game is in alpha. Everyone is testing and needs to be able to provide us with debugging info at any time (for a similar reason, I don't like the suggestion of "hiding" error messages, it's aesthetically ugly but demands attention and action)

Replying to elexis:

I've seen this function being used for different purposes by a bunch of players. Also who uses WASD to scroll and Alt+Doubleclick to select all units of one kind can open that overlay by accident, especially when experiencing #2809.

If it's known to happen frequently, those people could change the dev overlay hotkey.

I don't know how the lobby is moderated, but if people are in fact being banned for innocently opening the dev overlay due to bugs or whatever, then that sounds like a policy issue that needs to be discussed.

comment:6 Changed 4 years ago by elexis

Changing the perspective has been limited to cheating in r17170 / #2676.

If #3551 will be fixed and if we don't go with a gameattribute setting for the dev-overlay (as proposed in comment:5:ticket:2676), this ticket should be considered fixed (not closed-as-won't-fix).

comment:7 Changed 4 years ago by Josh

See #3579.

comment:8 Changed 3 years ago by Palaxin

Summary: [Patch] Allow the Developers Overlay only with cheats enabled[PATCH] Allow the Developers Overlay only with cheats enabled
Note: See TracTickets for help on using tickets.