Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4038 closed defect (needsinfo)

Game crashes when typing "ö" with VirtualGL drivers

Reported by: nolcip Owned by:
Priority: Must Have Milestone:
Component: Core engine Keywords:
Cc: Patch:

Description

Noticed in Alpha 20 but Alpha 19 also yields the same result.

The game crashes whenever non ascii characters such as ö,á, etc are inserted, even ~, ' alone, not only in the in-game chat but in the lobby as well.

To reproduce the error, just type these characters any of these text fields.

Crash report:

Short video: https://u.teknik.io/COE9t.webm

Both tested versions were build from source and are running on a Debian based distro.

Change History (5)

comment:1 Changed 3 years ago by elexis

Can't reproduce on Ubuntu 15.04 with any of the releases/svn version, at least with ö.

It is strange that this crashes in OsString / os_path.h though since that is used for directory/filenames.

comment:2 Changed 3 years ago by elexis

Component: Multiplayer lobbyCore engine
Keywords: chat characters removed

comment:3 Changed 3 years ago by sanderd17

I have no problem with typing ö on my USA-international keyboard layout (on which I have to type a dead ¨ followed by a regular o). And I'm on Arch Linux.

So I don't know whether it's Debian having problems, or it doesn't work with a German keyboard where the ö is a default key.

Second thought: é is a regular key, and the game doesn't crash on that, so it should be something Debian-specific I guess.

comment:4 Changed 3 years ago by nolcip

I did more testing and I noticed that it crashes when I'm running it with virtualgl drivers in bumblebee. If I run the game without bumblebee and no graphics acceleration it doesn't crash.

This problem seems to happen with other applications as well, but it is not consistent. I tested the chat in the game Xonotic, also running it with bumblebee, and I got the same error on terminal. While everything worked normally on several other applications (tested on proprietary Unity engine games and gtk applications).

comment:6 Changed 3 years ago by elexis

Milestone: Backlog
Resolution: needsinfo
Status: newclosed
Summary: Game crashes when typing "ö"Game crashes when typing "ö" with VirtualGL drivers

So it must be a bug in that VirtualGL version then.

Note: See TracTickets for help on using tickets.