Opened 10 months ago

Closed 8 months ago

Last modified 8 months ago

#4565 closed enhancement (fixed)

Tale of Warriors

Reported by: elexis Owned by: elexis
Priority: Should Have Milestone: Alpha 22
Component: Music & Sound FX Keywords:
Cc: Patch: Phab:D732


Omri plans to merge the song Tale Of Warriors with Alpha 22.

Change History (8)

comment:1 Changed 9 months ago by elexis

Milestone: Alpha 22Backlog

comment:2 Changed 8 months ago by elexis

Milestone: BacklogAlpha 22

I heard something that should be committed.

comment:3 Changed 8 months ago by stanislas69

Resolution: fixed
Status: newclosed

fixed by r19887, r19888, and r19889

comment:4 Changed 8 months ago by leper

It will however never be played unless someone adds it to the list of music tracks in the code.

comment:5 Changed 8 months ago by elexis

Resolution: fixed
Status: closedreopened

I'll reopen this just to remind us that we should add the track to some civ before the release.

To clarify: r19887 added the new song to the game.
r19888 added the wav source of that song and the old 8bit bonus track
r19889 removed two copies of audio tracks of the same directory
r19890 deleted the files from r19888
r19891 added the files from r19888 again with underscores instead of spaces

comment:6 Changed 8 months ago by elexis

Patch: Phab:D732

Patch also addresses two other unused songs, one song used 4 times and some civs only having two songs.

comment:7 Changed 8 months ago by elexis

Owner: set to elexis
Resolution: fixed
Status: reopenedclosed

In 19918:

Play more music tracks.

Register the new track "Tale Of Warriors" from rP19887 with the game.
Register "Calm Before the Storm" and "Tavern in the Mist", which were not heard in the previous releases.
Play some peace tracks for all civilizations, as intended by Omri (thus play some music for observers too, refs #4298).
Add more background tracks to the menu as agreed with WhiteTreePaladin?.
Keep "Honor Bound" the first one, as proposed by Itms and leper.
Add some tracks that are played only for one civ to other civs, to reduce the repetition.
Remove duplicate, now unused music code.

Differential Revision:
Fixes #4565.

comment:8 Changed 8 months ago by elexis

In r19919 by Omri:
Sunrise (short version that is planned to be extended next alpha) and delete duplicate victory track.

In r19920 by Omri:
Sunrise audio source

In r19921 by Itms:
Use Sunrise for Gauls.

Note: See TracTickets for help on using tickets.