Opened 18 months ago

Closed 17 months ago

Last modified 17 months ago

#5605 closed defect (fixed)

Unrecognizable trade resources and loot resources due to missing rounding

Reported by: bb Owned by:
Priority: Must Have Milestone: Alpha 24
Component: UI – In-game Keywords: regression
Cc: Patch:

Description

In the following replay at r22967 on minute 27 some blue traders say to have 488749619 metal on their carts. This obviously shouldn't be possible.

Attachments (2)

commands.txt (285.2 KB ) - added by bb 18 months ago.
commands.zip (514.5 KB ) - added by elexis 17 months ago.
Replay of unknown revision (but was the most recent at the time of the timestamp) where loot in the summary screen was equally bonkers, probably the trade cart loot.

Download all attachments as: .zip

Change History (5)

by bb, 18 months ago

Attachment: commands.txt added

comment:1 by elexis, 18 months ago

Keywords: regression added
Milestone: BacklogAlpha 24
Priority: Nice to HaveMust Have
Summary: Too large tradeUnrecognizable trade resources and loot resources due to missing rounding

At minute 13 one can see such a trade cart too.

The number is fractional, whereas previously it wasn't so. So the number 488749619 are just the last digits of the number, the numbers before the . are not shown.

This applies to the ingame trade resources tooltip and to the summary screen trade and loot.

comment:2 by stanislas69, 17 months ago

Resolution: fixed
Status: newclosed

by elexis, 17 months ago

Attachment: commands.zip added

Replay of unknown revision (but was the most recent at the time of the timestamp) where loot in the summary screen was equally bonkers, probably the trade cart loot.

comment:3 by elexis, 17 months ago

Trade issue fixed in r23016.

Fractional loot since r14247, visible with 0ad templates since r21128, still applies, see https://code.wildfiregames.com/D2327#97846.

Note: See TracTickets for help on using tickets.