Opened 2 years ago

Last modified 11 months ago

#6193 new defect

Inconsistent FPS stuttering when compiling against 10.14 (+?) SDK

Reported by: wraitii Owned by:
Priority: Should Have Milestone: Backlog
Component: Core engine Keywords:
Cc: Patch:

Description (last modified by Langbart)

Weird bug, this. As confirmed by myself and langbart, MacOs experiences FPS stuttering without frame rate limiting in some situations.

See:

From what I can tell, this doesn't happen:

  • when compiled against the 10.12 SDK (as does the CI)
  • when enabling High DPI in the SDL2 window
  • when limiting the frame rate below some magic number, but that's less consistent.

Sync doesn't really seem to affect it.

I have no clue what's causing this, and it ought naturally disappear when we shift to High DPI, and it doesn't affect bundles because of the SDK difference, so I'll leave this open to remind ourselves.

related ticket

  • #6593 (closed as duplicate, contains a lot of details)

Change History (3)

comment:1 by wraitii, 2 years ago

Milestone: Alpha 25Alpha 26

comment:2 by Freagarach, 13 months ago

Milestone: Alpha 26Backlog

comment:3 by Langbart, 11 months ago

Description: modified (diff)
Note: See TracTickets for help on using tickets.