Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1196 closed defect (worksforme)

Crash in wsdl.cpp:438 (SDL_SetVideoMode)

Reported by: plumo Owned by:
Priority: Release Blocker Milestone:
Component: Core engine Keywords:
Cc:

Description

Latest SVN version.

Attachments (2)

crashlog.txt (21.8 KB) - added by plumo 3 years ago.
system_info.txt (11.5 KB) - added by plumo 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by plumo

Changed 3 years ago by plumo

comment:1 in reply to: ↑ description Changed 3 years ago by plumo

Replying to plumo:

Latest SVN version.
Game gets stuck on loading screen (50 percent)

comment:2 Changed 3 years ago by historic_bruno

Can you run the game in a debugger, and put a breakpoint at wsdl.cpp:438 (SDL_SetVideoMode) to find the value of status? Then we can match it up with one of the return codes listed here, to find out why it's failing.

Also I'm not sure this qualifies as a release blocker.

comment:3 Changed 3 years ago by plumo

I will try tomorrow when I'm home.

comment:4 Changed 3 years ago by plumo

Ticket can be closed.

This error appears when clicking CTRL ALT DEL while loading a map.

comment:5 Changed 3 years ago by plumo

  • Resolution set to worksforme
  • Status changed from new to closed

comment:6 Changed 3 years ago by historic_bruno

  • Milestone Alpha 9 deleted

Ah, strange error. You have to be in fullscreen mode and then switch to the login screen while the game is loading. I found you can choose "Continue" in the error dialog and it will continue loading in windowed mode. If anyone's interested, the error is:

DISP_CHANGE_FAILED - The display driver failed the specified graphics mode.

Apparently, the problem is once you're on the login screen, you're no longer in the same desktop thread and you can't ChangeDisplaySettings on the current thread (obviously). I don't think this is a problem we can trivially solve, so the best advice may be: don't use Ctrl+Alt+Delete while the game is loading :)

(I do wonder if we can detect this situation though and either show a less scary message or make the application wait until the thread returns to the user's desktop)

Note: See TracTickets for help on using tickets.