Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3165 closed defect (fixed)

[PATCH] Persist Match Settings - Enabling Rated games breaks settings for non-lobby multiplayer games

Reported by: elexis Owned by: Itms
Priority: Nice to Have Milestone: Alpha 19
Component: UI & Simulation Keywords:
Cc: Patch:

Description

Reproduce: Host a lobby match with rated games enabled. Close. Host a multiplayer match without lobby. Teams will be locked, even if you try to disable it and cheats can never be enabled too.

This is forced by the enabled but invisible rated games option. The singleplayer settings are saved in a separate file and don't seem to be affected, since I can enabled and disable locked teams.

Fix: The persist match settings should ignore the rated games settings for non-lobby multiplayer matches and disable it by default, since that option is not available in the UI either.

Attachments (1)

fix_persist_match_settings_rated_games_t3165_r16533.patch (1.4 KB ) - added by elexis 8 years ago.
The second change in the patch is also required. Otherwise a new bug is introduced: Host a lobby game with ratings enabled; host a non-lobby game (ratings will become disabled), host a rated game -> cheats and teams locked setting will be disabled (not-clickable) although rated games are disabled.

Download all attachments as: .zip

Change History (5)

by elexis, 8 years ago

The second change in the patch is also required. Otherwise a new bug is introduced: Host a lobby game with ratings enabled; host a non-lobby game (ratings will become disabled), host a rated game -> cheats and teams locked setting will be disabled (not-clickable) although rated games are disabled.

comment:1 by elexis, 8 years ago

Keywords: review added; easy removed
Summary: Persist Match Settings - Enabling Rated games breaks settings for non-lobby multiplayer games[PATCH] Persist Match Settings - Enabling Rated games breaks settings for non-lobby multiplayer games

comment:2 by historic_bruno, 8 years ago

Keywords: patch added

comment:3 by Itms, 8 years ago

Owner: set to Itms
Resolution: fixed
Status: newclosed

In 16545:

Yet another fix for the gamesetup persistent settings.

Patch by elexis, fixes #3165

comment:4 by Itms, 8 years ago

Keywords: patch review removed

Thanks for the patch!

Note: See TracTickets for help on using tickets.