Opened 8 years ago

Closed 3 years ago

#4360 closed defect (fixed)

HWDetect for AMD Ryzen CPUs triggers Assertion failed: "cache.Validate()"

Reported by: c Owned by: Imarok
Priority: Release Blocker Milestone: Alpha 24
Component: Core engine Keywords:
Cc: Patch: Phab:D3031

Description (last modified by c)

Hi, I'm running the game on my debian setup triggers various errors. I first reported the problem on Debian's BTS (link). I thought the crash was total, but I can run the game to a certain point.

Please find attached (bubu2.log) what I managed to get with gdb. I didn't "continue" but exited on 1st error. I'm getting various backtraces depending on the way I proceeded so hopefully this one is the good one.

Attachments (6)

bubu2.log (28.1 KB ) - added by c 8 years ago.
bubu.log (970 bytes ) - added by c 8 years ago.
0adLaunch.txt (5.2 KB ) - added by J. Andrew Lanz-O'Brien 5 years ago.
Launch errors
LanzSpecs.txt (584 bytes ) - added by J. Andrew Lanz-O'Brien 5 years ago.
Ryzen 3800X system
userreport_hwdetect.txt (17.1 KB ) - added by J. Andrew Lanz-O'Brien 5 years ago.
system_info_Aug23.txt (8.0 KB ) - added by J. Andrew Lanz-O'Brien 5 years ago.

Download all attachments as: .zip

Change History (32)

by c, 8 years ago

Attachment: bubu2.log added

by c, 8 years ago

Attachment: bubu.log added

comment:1 by c, 5 years ago

Description: modified (diff)

I suppose this bug can be closed, I don't play 0ad regularly enough to confirm my tests but this particular problem doesn't seem to happen with current versions of 0ad.

comment:2 by Stan, 5 years ago

Milestone: Backlog
Resolution: needsinfo
Status: newclosed

Closing it as needinfo then. Thanks for the report back then.

by J. Andrew Lanz-O'Brien, 5 years ago

Attachment: 0adLaunch.txt added

Launch errors

by J. Andrew Lanz-O'Brien, 5 years ago

Attachment: LanzSpecs.txt added

Ryzen 3800X system

by J. Andrew Lanz-O'Brien, 5 years ago

Attachment: userreport_hwdetect.txt added

comment:3 by J. Andrew Lanz-O'Brien, 5 years ago

This is still happening to me on Arch Linux with their 0ad a23.1-4 package on kernel 5.3.0-rc4-gdcb8cfbd8fe9 #1 SMP PREEMPT Sat Aug 17 23:27:35 EDT 2019 x86_64 GNU/Linux on a Ryzen 3800X with Radeon 5700XT (see "LanzSpecs.txt" attachment for details).

comment:4 by Stan, 5 years ago

Are you by any chance missing the 0ad-data package ?

comment:5 by J. Andrew Lanz-O'Brien, 5 years ago

@stanislas69: I am not missing the 0ad-data package. 0ad-data is a dependency for the 0ad package on Arch Linux, and it is installed on my system, and the error occurs with it installed correctly.

comment:6 by elexis, 5 years ago

cache.Validate() is defined in cache.cpp, and that file is about detecting the CPU cache for the purpose of the UserReporter.

So probably one way to work around the crash is to disable the UserReporter.

That can be done by editing your user.cfg to replace or add this line:

userreport.enabledversion = "0"

wiki:GameDataPaths

But of course it would be better to fix the issue.

You have uploaded a userreporter file, but if the crash happens in the userreporter, then that file shouldn't be written? Can you rename the file and see if it is recreated? When does the crash happen, just after starting the program?

comment:7 by J. Andrew Lanz-O'Brien, 5 years ago

@elexis: I already have userreport.enabledversion = "0" in ~/.config/0ad/config/user.cfg

The game does not actually crash. It brings up the error in a window entitled "0 A.D. message" and I click "Continue" 3 times, then it comes to the normal 0 AD user interface.

comment:8 by elexis, 5 years ago

Ah, right, disabling the UserReport only means it's not uploaded, but the hardware data is still gathered by the program and the file still written to the local disk so that the user can hypothetically read the content that would be sent if hte user would agree to the terms (showing it was not implemented because the data was in a different thread and we were in gdpr-freeze).

So. The question is now from which time the userreport file is.

Because to me it sounds like you two guys used some hardware that 0ad doesn't support at the time it crashed. The code didn't change, so I suppose the hardware (or operating system / drivers?) of the previous reporter changed when the "crash" was gone?

So if it is a hardware or driver issue, then we should know which hardware (I guess CPU cache) that is. The userreport.json should show the data, but I suspect that it was not generated with the hardware that crashes. Hence it would be good to know if that file is actually generated when you run the program, or whether that is aborted when the error messages pop up.

comment:10 by elexis, 5 years ago

Milestone: Backlog

If janwas was the last one 6 years ago to update some CPU hardcodings then the task description sounds a lot like that should be updated, in particular for the CPU of the one experiencing the error.

Andrew (I don't see the nickname for some reason), can you upload the /home/user/.config/0ad/logs/system_info.txt file? And ensure that this file is written with the computer that has the crash/error? (you can rename or delete the file, start the program again to recreate it.)

comment:11 by elexis, 5 years ago

Component: UI & SimulationCore engine
Resolution: needsinfo
Status: closedreopened

by J. Andrew Lanz-O'Brien, 5 years ago

Attachment: system_info_Aug23.txt added

comment:12 by J. Andrew Lanz-O'Brien, 5 years ago

Thanks for continuing to debug this, @stanislas69 and @elexis. I've attached the system_info.txt file that I just generated on my machine. It's a Ryzen 3800X CPU.

comment:13 by elexis, 5 years ago

I suppose the task description is to fix the hardware detection to work with that hardware, but also to consider whether exceptions could be caught in general, or at least to provide a way to configure 0ad to not run that code that can crash on unknown hardware, that would be HWDetect.cpp.

Being able to skip HWDetect should probably be exposed through the User-Interface, so it's related to the task of providing the user a way to show the data, or write the file only upon request.

(There was also a privacy concern, currently the userinterface can't read hardware data, so they can'T abuse the data. But they could if we would add a way to show it in the userinterface. So probably should be a save-to-disk button only and showing the resulting filename.)

comment:14 by elexis, 5 years ago

Summary: Assertion failed: "cache.Validate()"HWDetect for recent CPUs triggers Assertion failed: "cache.Validate()"

comment:15 by Holzhuette, 5 years ago

I can confirm this bug.

I have built 2 identical systems; one with a ryzen 2400G and one with a ryzen 3600 If i put the harddisk in the first one, 0AD runs without error, When I put the harddisk in the second one, I get this error. After clicking continue for 3 times it starts the game , but only in windowed mode.

Looks like the ryzen zen2 platform is not yet supported.

Hope this will be resolved soon. We are regular players of this great game and a.t.m. the one using the new ryzen (3000 series) can't join. Sad faces all around ;-(

comment:16 by Stan, 5 years ago

What OS are you on ? You could compile the game with a little fix :)

comment:17 by Holzhuette, 5 years ago

(generated 2019-09-28 14:49:08 UTC)

OS             : Linux 5.2.11-1-MANJARO (#1 SMP PREEMPT Thu Aug 29 07:41:24 UTC 2019)
CPU            : x86_64, AMD Ryzen 5 3600 6-Core Processor     (1x12x1), 3.59 GHz
Memory         : 15968 MiB; 4430 MiB free
Graphics Card  : X.Org Radeon RX 570 Series (POLARIS10, DRM 3.32.0, 5.2.11-1-MANJARO, LLVM 8.0.1)
OpenGL Drivers : 4.5 (Compatibility Profile) Mesa 19.1.5; OpenGL 4.5 (Compatibility Profile) Mesa 19.1.5
Video Mode     : 1024x768:24
Sound Card     : Starship/Matisse HD Audio Controller Analog Stereo; Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 3); 
Sound Drivers  : 1.1 ALSOFT 1.19.1

OpenGL Extensions: 
GL_ARB_multisample
GL_EXT_abgr
GL_EXT_bgra
GL_EXT_blend_color
GL_EXT_blend_minmax
GL_EXT_blend_subtract
GL_EXT_copy_texture
GL_EXT_subtexture
GL_EXT_texture_object
GL_EXT_vertex_array
GL_EXT_compiled_vertex_array
GL_EXT_texture
GL_EXT_texture3D
GL_IBM_rasterpos_clip
GL_ARB_point_parameters
GL_EXT_draw_range_elements
GL_EXT_packed_pixels
GL_EXT_point_parameters
GL_EXT_rescale_normal
GL_EXT_separate_specular_color
GL_EXT_texture_edge_clamp
GL_SGIS_generate_mipmap
GL_SGIS_texture_border_clamp
GL_SGIS_texture_edge_clamp
GL_SGIS_texture_lod
GL_ARB_framebuffer_sRGB
GL_ARB_multitexture
GL_EXT_framebuffer_sRGB
GL_IBM_multimode_draw_arrays
GL_IBM_texture_mirrored_repeat
GL_ARB_texture_cube_map
GL_ARB_texture_env_add
GL_ARB_transpose_matrix
GL_EXT_blend_func_separate
GL_EXT_fog_coord
GL_EXT_multi_draw_arrays
GL_EXT_secondary_color
GL_EXT_texture_env_add
GL_EXT_texture_filter_anisotropic
GL_EXT_texture_lod_bias
GL_INGR_blend_func_separate
GL_NV_blend_square
GL_NV_light_max_exponent
GL_NV_texgen_reflection
GL_NV_texture_env_combine4
GL_S3_s3tc
GL_SUN_multi_draw_arrays
GL_ARB_texture_border_clamp
GL_ARB_texture_compression
GL_EXT_framebuffer_object
GL_EXT_texture_compression_s3tc
GL_EXT_texture_env_combine
GL_EXT_texture_env_dot3
GL_MESA_window_pos
GL_NV_packed_depth_stencil
GL_NV_texture_rectangle
GL_ARB_depth_texture
GL_ARB_occlusion_query
GL_ARB_shadow
GL_ARB_texture_env_combine
GL_ARB_texture_env_crossbar
GL_ARB_texture_env_dot3
GL_ARB_texture_mirrored_repeat
GL_ARB_window_pos
GL_ATI_fragment_shader
GL_EXT_stencil_two_side
GL_EXT_texture_cube_map
GL_NV_depth_clamp
GL_NV_fog_distance
GL_APPLE_packed_pixels
GL_ARB_draw_buffers
GL_ARB_fragment_program
GL_ARB_fragment_shader
GL_ARB_shader_objects
GL_ARB_vertex_program
GL_ARB_vertex_shader
GL_ATI_draw_buffers
GL_ATI_texture_env_combine3
GL_ATI_texture_float
GL_EXT_depth_bounds_test
GL_EXT_shadow_funcs
GL_EXT_stencil_wrap
GL_MESA_pack_invert
GL_NV_primitive_restart
GL_ARB_depth_clamp
GL_ARB_fragment_program_shadow
GL_ARB_half_float_pixel
GL_ARB_occlusion_query2
GL_ARB_point_sprite
GL_ARB_shading_language_100
GL_ARB_sync
GL_ARB_texture_non_power_of_two
GL_ARB_vertex_buffer_object
GL_ATI_blend_equation_separate
GL_EXT_blend_equation_separate
GL_OES_read_format
GL_ARB_color_buffer_float
GL_ARB_pixel_buffer_object
GL_ARB_texture_compression_rgtc
GL_ARB_texture_float
GL_ARB_texture_rectangle
GL_ATI_texture_compression_3dc
GL_EXT_packed_float
GL_EXT_pixel_buffer_object
GL_EXT_texture_compression_dxt1
GL_EXT_texture_compression_rgtc
GL_EXT_texture_mirror_clamp
GL_EXT_texture_rectangle
GL_EXT_texture_sRGB
GL_EXT_texture_shared_exponent
GL_ARB_framebuffer_object
GL_EXT_framebuffer_blit
GL_EXT_framebuffer_multisample
GL_EXT_packed_depth_stencil
GL_ARB_vertex_array_object
GL_ATI_separate_stencil
GL_ATI_texture_mirror_once
GL_EXT_draw_buffers2
GL_EXT_draw_instanced
GL_EXT_gpu_program_parameters
GL_EXT_gpu_shader4
GL_EXT_texture_array
GL_EXT_texture_compression_latc
GL_EXT_texture_integer
GL_EXT_texture_sRGB_decode
GL_EXT_timer_query
GL_OES_EGL_image
GL_AMD_performance_monitor
GL_EXT_texture_buffer_object
GL_AMD_texture_texture4
GL_ARB_copy_buffer
GL_ARB_depth_buffer_float
GL_ARB_draw_instanced
GL_ARB_half_float_vertex
GL_ARB_instanced_arrays
GL_ARB_map_buffer_range
GL_ARB_texture_buffer_object
GL_ARB_texture_rg
GL_ARB_texture_swizzle
GL_ARB_vertex_array_bgra
GL_EXT_texture_swizzle
GL_EXT_vertex_array_bgra
GL_NV_conditional_render
GL_AMD_conservative_depth
GL_AMD_depth_clamp_separate
GL_AMD_draw_buffers_blend
GL_AMD_seamless_cubemap_per_texture
GL_AMD_shader_stencil_export
GL_ARB_ES2_compatibility
GL_ARB_blend_func_extended
GL_ARB_compatibility
GL_ARB_debug_output
GL_ARB_draw_buffers_blend
GL_ARB_draw_elements_base_vertex
GL_ARB_explicit_attrib_location
GL_ARB_fragment_coord_conventions
GL_ARB_provoking_vertex
GL_ARB_sample_shading
GL_ARB_sampler_objects
GL_ARB_seamless_cube_map
GL_ARB_shader_stencil_export
GL_ARB_shader_texture_lod
GL_ARB_tessellation_shader
GL_ARB_texture_buffer_object_rgb32
GL_ARB_texture_cube_map_array
GL_ARB_texture_gather
GL_ARB_texture_multisample
GL_ARB_texture_query_lod
GL_ARB_texture_rgb10_a2ui
GL_ARB_uniform_buffer_object
GL_ARB_vertex_type_2_10_10_10_rev
GL_ATI_meminfo
GL_EXT_provoking_vertex
GL_EXT_texture_snorm
GL_MESA_texture_signed_rgba
GL_NV_texture_barrier
GL_ARB_draw_indirect
GL_ARB_get_program_binary
GL_ARB_gpu_shader5
GL_ARB_gpu_shader_fp64
GL_ARB_robustness
GL_ARB_separate_shader_objects
GL_ARB_shader_bit_encoding
GL_ARB_shader_precision
GL_ARB_shader_subroutine
GL_ARB_texture_compression_bptc
GL_ARB_timer_query
GL_ARB_transform_feedback2
GL_ARB_transform_feedback3
GL_ARB_vertex_attrib_64bit
GL_ARB_viewport_array
GL_EXT_vertex_attrib_64bit
GL_NV_vdpau_interop
GL_AMD_multi_draw_indirect
GL_ANGLE_texture_compression_dxt3
GL_ANGLE_texture_compression_dxt5
GL_ARB_base_instance
GL_ARB_compressed_texture_pixel_storage
GL_ARB_conservative_depth
GL_ARB_internalformat_query
GL_ARB_map_buffer_alignment
GL_ARB_shader_atomic_counters
GL_ARB_shader_image_load_store
GL_ARB_shading_language_420pack
GL_ARB_shading_language_packing
GL_ARB_texture_storage
GL_ARB_transform_feedback_instanced
GL_EXT_framebuffer_multisample_blit_scaled
GL_EXT_transform_feedback
GL_AMD_query_buffer_object
GL_AMD_shader_trinary_minmax
GL_AMD_vertex_shader_layer
GL_AMD_vertex_shader_viewport_index
GL_ARB_ES3_compatibility
GL_ARB_arrays_of_arrays
GL_ARB_clear_buffer_object
GL_ARB_compute_shader
GL_ARB_copy_image
GL_ARB_explicit_uniform_location
GL_ARB_fragment_layer_viewport
GL_ARB_framebuffer_no_attachments
GL_ARB_invalidate_subdata
GL_ARB_multi_draw_indirect
GL_ARB_program_interface_query
GL_ARB_robust_buffer_access_behavior
GL_ARB_shader_image_size
GL_ARB_shader_storage_buffer_object
GL_ARB_stencil_texturing
GL_ARB_texture_buffer_range
GL_ARB_texture_query_levels
GL_ARB_texture_storage_multisample
GL_ARB_texture_view
GL_ARB_vertex_attrib_binding
GL_KHR_debug
GL_KHR_robustness
GL_KHR_texture_compression_astc_ldr
GL_AMD_pinned_memory
GL_ARB_bindless_texture
GL_ARB_buffer_storage
GL_ARB_clear_texture
GL_ARB_compute_variable_group_size
GL_ARB_enhanced_layouts
GL_ARB_indirect_parameters
GL_ARB_internalformat_query2
GL_ARB_multi_bind
GL_ARB_query_buffer_object
GL_ARB_seamless_cubemap_per_texture
GL_ARB_shader_draw_parameters
GL_ARB_shader_group_vote
GL_ARB_texture_mirror_clamp_to_edge
GL_ARB_texture_stencil8
GL_ARB_vertex_type_10f_11f_11f_rev
GL_EXT_shader_integer_mix
GL_NVX_gpu_memory_info
GL_ARB_ES3_1_compatibility
GL_ARB_clip_control
GL_ARB_conditional_render_inverted
GL_ARB_cull_distance
GL_ARB_derivative_control
GL_ARB_direct_state_access
GL_ARB_get_texture_sub_image
GL_ARB_pipeline_statistics_query
GL_ARB_shader_texture_image_samples
GL_ARB_sparse_buffer
GL_ARB_texture_barrier
GL_ARB_transform_feedback_overflow_query
GL_EXT_polygon_offset_clamp
GL_EXT_shader_image_load_formatted
GL_KHR_blend_equation_advanced
GL_KHR_context_flush_control
GL_KHR_robust_buffer_access_behavior
GL_ARB_parallel_shader_compile
GL_ARB_shader_atomic_counter_ops
GL_ARB_shader_ballot
GL_ARB_shader_clock
GL_ARB_shader_viewport_layer_array
GL_KHR_no_error
GL_KHR_texture_compression_astc_sliced_3d
GL_EXT_window_rectangles
GL_MESA_shader_integer_functions
GL_ARB_polygon_offset_clamp
GL_ARB_texture_filter_anisotropic
GL_EXT_memory_object
GL_EXT_memory_object_fd
GL_EXT_semaphore
GL_EXT_semaphore_fd
GL_KHR_parallel_shader_compile
GL_AMD_framebuffer_multisample_advanced
GL_EXT_texture_sRGB_R8 

SMBIOS: 


in reply to:  16 comment:18 by Holzhuette, 5 years ago

Replying to stanislas69:

What OS are you on ? You could compile the game with a little fix :)

I'm not a regular compiler, but it should be possible on my manjaro, and i could give it a shot! My eyes and ears are open!

comment:19 by Stan, 5 years ago

You should be done with those few steps

  • If you want A23B
 svn checkout -r 21946 https://svn.wildfiregames.com/public/ps/trunk/

Or

If you want the very latest dev version

svn checkout -r https://svn.wildfiregames.com/public/ps/trunk/

Once checkout is complete (might take a while) you will need to apply a patch.

cd into the root of the folder you just cloned

Run to download the

 wget -O cache.diff https://code.wildfiregames.com/file/data/qqy7k
i7tzte7g4txd2cw/PHID-FILE-siatba2f63gdroqdzxp4/raw.txt

Then to apply the patch

patch -p 0 < cache.diff 

Then you need to follow the BuildInstructions to build the game.

Dependencies are here https://trac.wildfiregames.com/wiki/BuildInstructions#ArchLinux

comment:20 by elexis, 5 years ago

Milestone: BacklogAlpha 24
Summary: HWDetect for recent CPUs triggers Assertion failed: "cache.Validate()"HWDetect for AMD Ryzen CPUs triggers Assertion failed: "cache.Validate()"

I can't guarantee that someone will fix it, but I can put it on the milestone so that at least one will have to reconsider it before the next release.

Perhaps it would even be a good addition to wiki:ReleaseProcessDraft to update it once per release.

comment:22 by Imarok, 5 years ago

Patch: Phab:D2353

Phab:D2353 will fix that. Please try it out. :)

comment:23 by Imarok, 5 years ago

Owner: set to Imarok
Resolution: fixed
Status: reopenedclosed

In 23262:

Workaround for L3 cache detection of Ryzen 3000

This code is planned to get refactored or removed anyway, so just do a cheap workaround.

Reviewed by: Imarok
Fixes: #4360
Differential Revision: https://code.wildfiregames.com/D2353

comment:24 by OptimusShepard, 4 years ago

Patch: Phab:D2353Phab:D3031
Priority: Should HaveRelease Blocker
Resolution: fixed
Status: closedreopened
Last edited 4 years ago by OptimusShepard (previous) (diff)

comment:25 by Imarok, 4 years ago

Alternative solution (deleting all cache detection): Phab:D3165

comment:26 by Imarok, 3 years ago

Resolution: fixed
Status: reopenedclosed

In 24550:

Remove cache detection

Reviewed by: wraitii
Fixes: #4360
Differential Revision: https://code.wildfiregames.com/D3165

Note: See TracTickets for help on using tickets.